AppSync:尝试更改归档日志目标的所有者时,Oracle 数据库恢复失败

Summary: 归档日志目录的 Chown 命令失败,因为装载主机上不存在该目录本身。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



尝试装载和恢复 Oracle 数据库拷贝时,服务计划在“pre-Recover Database”步骤中失败,并显示以下错误:

服务计划事件将显示:
恢复拷贝, MILE_000005,< AppSync 服务器>, DBNAME> 的<恢复拷贝阶段已完成,但有错误
恢复拷贝, GENL_000055,AppSync< 服务器>, 在主机 <MOUNTHOST> 上运行 preRecoverDatabase 时出错。有关更多详细信息,请参阅代理主机上的xxx.log。

AppSync 服务器日志将显示:
ERROR [EJB default - 6] [com.emc.archway.service.sshservice.SshServiceBean] [<AppSync Server>] [] ->>> ACP failed, dumping stderr:Traceback (most recent call last):
  文件“/usr/local/lib/python3.3/site-packages/cx_Freeze/initscripts/Console3.py”,第 27 行,在<“文件”acp.py“模块
>中,第 146 行,在”文件“acp.py”模块>
中<,第 118 行,在主
文件“generic/oracle.py”中,第 117 行,在运行
文件“generic/oracle.py”中,第 618 行,在 preRecoverDatabase
文件“generic/oracle.py”中,第 2928 行,在 preRecoverDatabase
文件“generic/oracle.py”中,第 4458 行,在 changeOwner
中 执行
acputil 中的文件“/jenkins/lglbi061/workspace/Build-Linux-3.8.0.0/urm/appsync/3.8.0.0/integration/acp/src/appsync/acputil.py”,第 656 行。ShellException:命令 'chown -R 1000:1000 /archives/
<Filesystem name>/' 失败,并显示错误代码 1:['chown: 无法访问 \u20xx/archives/<文件系统名称>/\u20yy:No such file or directory']

服务计划事件中提及的装载主机上的 AppSync 插件程序日志将显示正在执行的命令,但不会出现任何内容,如下所示:
acputil.py[643]:execute() Info:运行命令:chown -R 1000:1000 /archives/<DBNAME/>

Cause

归档日志目录在创建 Oracle 数据库时创建为 /archive/<Filesystem name> ,但装载该目录的文件系统名称是 /archive。在 AppSync 数据库中,归档目标保存为 /archive/<Filesystem name>,与创建数据库时提供的相同名称。

当 AppSync 装载拷贝并尝试恢复时,它会从 AppSync 数据库中获取目标,并尝试更改目标的所有权。由于 AppSync 将其装载为 /archive,因此装载主机上不存在 /archive/<文件系统名称> 。原因是没有在 /archive 的“路径映射设置”中指定路径,这会默认将其装载到装载主机上的 /archive。

装载主机上不存在目录 /archive/<Filesystem 名称> ,但在更改权限时,AppSync 会从数据库中查找名称。

Resolution

AppSync 工程部门已针对此问题发布了一个修补程序。请向 Dell EMC 技术支持部门开具票证,并引用此文章 ID 以获取热修复程序。

此热修复程序将合并到 AppSync 的未来版本中。查看未来的发行说明,确认此问题是否已在要安装的版本中得到解决。

Additional Information

此内容已翻译成不同的语言: 
https://downloads.dell.com/TranslatedPDF/AR-SA_537205.pdf
https://downloads.dell.com/TranslatedPDF/DE_537205.pdf
https://downloads.dell.com/TranslatedPDF/ES_537205.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_537205.pdf
https://downloads.dell.com/TranslatedPDF/FR_537205.pdf
https://downloads.dell.com/TranslatedPDF/IT_537205.pdf
https://downloads.dell.com/TranslatedPDF/JA_537205.pdf
https://downloads.dell.com/TranslatedPDF/KO_537205.pdf
https://downloads.dell.com/TranslatedPDF/NL_537205.pdf
https://downloads.dell.com/TranslatedPDF/PT_537205.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_537205.pdf
https://downloads.dell.com/TranslatedPDF/RU_537205.pdf
https://downloads.dell.com/TranslatedPDF/SV_537205.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_537205.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_537205.pdf

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168360
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.