SourceOne: 처음에 선택할 폴더 목록을 표시한 후 두 번째 시도에서 웹 검색 복원 창에 사서함 폴더가 표시되지 않음
Summary: 시간 초과 오류로 인해 SourceOne Web Search Restore 창에서 폴더 목록을 로드하지 못했습니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
사용자가 SourceOne Web Search를 사용하고 있고 선택한 메시지를 Microsoft Exchange 사서함 폴더로 복원하기 위해 "Restore" 버튼을 선택하면 초기 복원 시도 창에 폴더 목록이 표시됩니다. 이후 "Restore" 버튼을 선택하면 복원 창에 사서함 폴더가 성공적으로 로드되지 않습니다.
다음은 복원 창이 어떻게 보이는지에 대한 예입니다.
브라우저 내의 개발자 툴을 사용하는 경우 다음과 유사한 오류 메시지가 나타날 수 있습니다.
다음은 복원 창이 어떻게 보이는지에 대한 예입니다.
브라우저 내의 개발자 툴을 사용하는 경우 다음과 유사한 오류 메시지가 나타날 수 있습니다.
Navigated to http://localhost/SEARCH/Restore.aspx favicon.ico:1 GET http://localhost/favicon.ico 404 (Not Found) ScriptResource.axd?d=78G0Omd0Kv__hpA1m1w13E5yK4XDO9aHSxVcfebeXUMF-eee66VovRG1HcTLFM-bbG2N5Qmv2-XjKMXO-f65ZVHBtcrp4C7DzelHUZZ7c61HePGWecVri7pk-kkp-Xrf1ytMoxWrcOO58uHi-vqbBXBkr1-hHhCRsBNTkUZZMWCfzXRQLmDkvvRCH-thmuva0&t=ffffffffecf19baa:5 Uncaught Sys.WebForms.PageRequestManagerTimeoutException: Sys.WebForms.PageRequestManagerTimeoutException: The server request timed out.
Cause
이 문제는 SDR 63291에 명시된 소프트웨어 결함으로 인해 발생합니다.
이후 시도에서 폴더 목록을 표시하려고 할 때 일부 환경에서는 프로그래밍 방식 호출에 대한 응답을 완료하는 데 걸리는 시간이 Restore.aspx 파일에 설정된 하드 코드된 제한인 90초보다 더 오래 걸릴 수 있습니다.
이후 시도에서 폴더 목록을 표시하려고 할 때 일부 환경에서는 프로그래밍 방식 호출에 대한 응답을 완료하는 데 걸리는 시간이 Restore.aspx 파일에 설정된 하드 코드된 제한인 90초보다 더 오래 걸릴 수 있습니다.
Resolution
이 문제는 7.2.SP10 HF3(7.2.10.0076) 이후 Dell EMC SourceOne Email Management의 패치 또는 서비스 팩 버전에서 해결됩니다. Dell EMC SourceOne 패치 및 서비스 팩 키트는 https://support.dell.com에서 다운로드할 수 있습니다.
EMC SourceOne Email Management 7.2.SP9 및 7.2.SP10을 실행하는 고객이 사용할 수 있는 핫픽스가 있습니다. EMC 기술 지원 부서에 문의하여 지원 참고 문서 및 SDR 번호(63291)를 지원 담당자와 공유하십시오.
사이트마다 프로그래밍 방식의 호출에 더 오랜 시간이 걸리는 이유가 다를 수 있습니다. 다음 단계에 따라 시간 초과를 늘릴 수 있습니다. 지연의 근본 원인을 식별할 수 없는 경우 선택을 위해 폴더 목록을 표시할 수 있습니다.
변경한 후 web.config 파일을 저장하고 닫습니다.
참고: 값은 밀리초 단위입니다. 180000으로 설정된 값은 180초 시간 초과를 허용합니다. 고객 환경에 따라 변경될 수 있습니다. 예를 들어 2분 시간 초과를 설정하는 경우 값은 120000이 됩니다.
EMC SourceOne Email Management 7.2.SP9 및 7.2.SP10을 실행하는 고객이 사용할 수 있는 핫픽스가 있습니다. EMC 기술 지원 부서에 문의하여 지원 참고 문서 및 SDR 번호(63291)를 지원 담당자와 공유하십시오.
사이트마다 프로그래밍 방식의 호출에 더 오랜 시간이 걸리는 이유가 다를 수 있습니다. 다음 단계에 따라 시간 초과를 늘릴 수 있습니다. 지연의 근본 원인을 식별할 수 없는 경우 선택을 위해 폴더 목록을 표시할 수 있습니다.
- Dell EMC 지원 팀에서 라이브러리 파일을 구하거나 수정 사항이 포함된 SourceOne Email Management 버전을 사용 중인지 확인하십시오. Dell EMC 지원 팀에서 라이브러리 파일을 받은 경우 기존 바이너리를 백업하고 라이브러리 파일이 포함된 SourceOne Web Search 설치 폴더에 제공된 새 바이너리를 설치합니다(예: "E:\Program Files (x86)\EMC SourceOne\Search\WebApp\bin").
- web.config 파일이 포함된 SourceOne Web Search 설치 디렉토리로 이동합니다(예: "E:\Program Files (x86)\EMC SourceOne\Search\WebApp").
- web.config 파일의 복사본을 만들어 다른 위치에 원래 구성 파일의 백업으로 저장합니다.
- web.config 파일을 편집하고 appSettings <> /appSettings> 섹션 내에서 <다음 줄을 추가합니다.
<키 추가 = "SearchWebServiceTimeoutSeconds"값 = "180000"/>
변경한 후 web.config 파일을 저장하고 닫습니다.
참고: 값은 밀리초 단위입니다. 180000으로 설정된 값은 180초 시간 초과를 허용합니다. 고객 환경에 따라 변경될 수 있습니다. 예를 들어 2분 시간 초과를 설정하는 경우 값은 120000이 됩니다.
- SourceOne Web Search 및 테스트 복원 작업에 로그인합니다.
Additional Information
Microsoft Outlook 2013, 2016 또는 2019가 설치된 SourceOne Web Search 서버에서 문제가 발견됩니다. SourceOne Web Search 서버에서 Outlook 2010 SP2를 설치하면 문제가 해결됩니다. 이 KB 문서를 작성하는 시점(2021년 5월 3일)의 Microsoft Outlook 버전 2013, 2016 또는 2019에 대한 최신 업데이트로는 문제가 해결되지 않습니다.
Affected Products
SourceOne, SourceOne, SourceOne Archiving, SourceOne Email ManagementArticle Properties
Article Number: 000186076
Article Type: Solution
Last Modified: 02 Sept 2025
Version: 9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.