Isilon: Gen6: Node startet nicht mit der Fehlermeldung "Receipt Update für Hardwareupgrade kann nicht durchgeführt werden"

Summary: Der Gen6-Node kann während der PSI-Konfigurationsphase nicht gestartet werden, wobei das Skript "isi_upgrade_hardware" ausgeführt wird, gefolgt von der Fehlermeldung "Kein Belegupdate für Hardwareupgrade durchgeführt". ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Der Gen6-Node kann während der PSI-Konfigurationsphase nicht gestartet werden, wobei das Skript "isi_upgrade_hardware" ausgeführt wird, gefolgt von der Fehlermeldung "Kein Belegupdate für Hardwareupgrade durchgeführt". Dies kann nach einem kürzlich durchgeführten Hardwareupgrade auf dem Cluster auftreten, z. B. EINEM DIMM-, NIC- oder SSD-Upgrade. Das Ende der Startsequenz sieht in etwa wie folgt aus (wichtige Zeilen sind fett gedruckt):

2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aktualisierungsbeleg für Hardwareupgrade
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aktualisieren der Quittung – cmd: /usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json FE 002-iFEIO-10GBE-B-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aktualisieren der Quittung – cmd: /usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json MODEL_BOM,compute 001-infinity-compute-low-64GB-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aktualisieren der Quittung – cmd: /usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json MODEL_BOM,SSD 001-infinity-ssd-1x400gb-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Nächster Schritt: Führen Sie isi_upgrade_hardware --node --validate aus
.2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Automatische Austauscherkennung bereits aktiviert
2021-05-05T11:56:16-07:00 isi_upgrade_hardware[470]: HW-Upgrade von gconfig kann nicht analysiert werden: (Upgrade in hwupgrade.upgrades): Datei oder Verzeichnis
dieser Art nicht vorhanden2021-05-05T11:56:16-07:00 Python: [520] WARNUNG: IPMI-Fehler: rv=0, CC=0xc1. IPMB-Adresse: 0x20 cmd: 0xbf, netfn: 0x30, cmd-Daten: [01]
2021-05-05T11:56:16-07:00 Python: [520] WARNUNG: CC[c1]: Ungültiger Befehl.
2021-05-05T11:56:16-07:00 Python: bootstrap_get_minbay: minbay 1, major 0, minor 0, waited 0 sec 6458 usec
Quittungsaktualisierung für Hardwareupgrade
kann nicht durchgeführt werden Um eine DL-Situation zu vermeiden, wenden Sie sich sofort an den Dell EMC Kundensupport:

Cause

Das letzte Hardwareupgrade wurde mit einer älteren Version des isi_hardware_upgrade Skripts ausgeführt, die einen Fehler enthielt, der dazu führte, dass die Bereinigungsphase des Prozesses nicht erfolgreich abgeschlossen wurde. Die Datei /root/node_hardware_upgrade.json wurde auf dem Node zurückgelassen. Dies lässt den Node glauben, dass er sich noch mitten in einem Hardwareupgrade befindet, und versucht, den nächsten Schritt im Prozess auszuführen, was fehlschlägt, da noch kein Upgrade durchgeführt wird. Dadurch wird verhindert, dass der Node den Startvorgang abschließt.

Resolution

1. Überprüfen Sie zunächst mit dem Kunden und allen anwesenden Außendienstmitarbeitern, dass derzeit kein Hardwareupgrade durchgeführt wird. Drücken Sie dann im Recovery-Shell-Menü die Taste 1, um die Recovery-Shell aufzurufen, und drücken Sie dann die Eingabetaste, um die Standard-Shell zu laden.

2. Überprüfen Sie, ob die folgende Datei auf dem Node vorhanden ist: /root/node_hardware_upgrade.json

3. Falls gefunden, benennen Sie diese Datei um und starten Sie den Node neu:

# mv /root/node_hardware_upgrade.json /root/node_hardware_upgrade.json.bak
# reboot


4. Wenn der Node erfolgreich gestartet wird, wird empfohlen, die anderen Nodes im Cluster präventiv auf das Vorhandensein dieser Datei zu überprüfen und sie zu entfernen, wenn sie gefunden wird:
# isi_for_array -s 'mv /root/node_hardware_upgrade.json /root/node_hardware_upgrade.json.bak'

Affected Products

Isilon, Isilon A200
Article Properties
Article Number: 000191007
Article Type: Solution
Last Modified: 26 Aug 2022
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.