Isilon: OneFS 9.2, 9.3: WebUI restricting Top Level Domain (TLD) length in some email address fields
Summary: In some areas of the WebUI, the email address field will only allow three or four characters for Top Level Domain (TLD).
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
In OneFS 9.2x & 9.3.x, the TLD of email addresses are limited in the WebUI:
- CELOG alert channels allow up to four characters. Entering a fifth character results in the message "Please enter a correct email address" as seen here:

- Email fields under General settings will allow up to three characters for the TLD. Entering a fourth character results in the message "Must be a valid email address" as seen here:

Cause
A change to the WebUI introduced in OneFS 9.2.0.0 changed the restrictions on TLDs of email addresses.
Resolution
Engineering is aware of the issue and is developing a fix to be released in a later Roll Up Patch (RUP).
As a workaround, the full email address can be entered using the CLI. CELOG alerts are sent to the entered email address.
However, once using the CLI to enter the email address, the WebUI can no longer be used for further changes as the error message is still displayed. Continue to use the CLI to make changes that would otherwise be made on the associated web page.
Article Properties
Article Number: 000198094
Article Type: Solution
Last Modified: 14 Jul 2023
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.