「Avamar:バックアップが応答を停止するか、ファイル システムのバックアップが「致命的なサーバー エラーが発生しました」で失敗する

Summary: Avamarバックアップが「avtar FATAL」で失敗する <5704>です。致命的なサーバー エラーが発生しました(MSG_ERR_AUTH_FAIL)。 バックアップを処理するには、グローバル ストレージ エリア ネットワーク(GSAN)と管理コンソール サービス(MCS)の間でセッション チケットを適切に同期する必要があります。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

以下のログが生成され、バックアップが失敗しています。

 

Avamar GSANのerr.logには、次のように表示される場合があります。

[srvm-518654#srv:481]  WARN: <1479> sessionkeytable::setpublickey new serial=<x> less than current minserial=<y>
...
[srvm-525136#srv:775]  WARN: <1426> sessionkeytable::comparesignature incorrect signature

 

Avtarログには次のように表示されます。

2019-12-31 07:35:23 avtar Error <8609>: Connection killed from GSAN. (Log #1) 
2019-12-31 07:35:23 avtar FATAL <5704>: Fatal Server Error occurred (MSG_ERR_AUTH_FAIL), aborting execution (SECURETICKETLOGIN=452 serial=1 seq=0 flags=R:H:0 kind=0 rsp=MSG_ERR_AUTH_FAIL) (Log #1) 
2019-12-31 07:35:23 avtar Error <5126>: Login error 5: Authorization failure (Session Ticket login) (Log #1) 
2019-12-31 07:35:23 avtar FATAL <8941>: Fatal server connection problem, aborting initialization. Verify correct server address and login credentials. (Log #1) 
2019-12-31 07:35:23 avtar Error <7001>: Exiting avtar with run-at-end script failure -1 (Log #1)
9-12-31 07:35:23 avtar Info <8474>: - Log file path: /usr/local/avamar/var/clientlogs/some-Unix.log
2019-12-31 07:35:23 avtar Info <6555>: Initializing connection
2019-12-31 07:35:23 avtar Info <5552>: Connecting to Avamar Server (avamar.com)
2019-12-31 07:35:23 avtar Info <5554>: Connecting to one node in each datacenter
2019-12-31 07:35:23 avtar Info <5993>: - Connect: Connected to 10.x.x.x:29000, Priv=0, SSL Cipher=AES256-SHA
2019-12-31 07:35:23 avtar Info <5993>: - Datacenter 0 has 1 nodes: Connected to 10.x.x.x:29000, Priv=0, SSL Cipher=AES256-SHA
2019-12-31 07:35:23 avtar Info <5581>: Logging in on connection 0 with Session Ticket
2019-12-31 07:35:23 avtar Info <18854>: Using Secure Session Ticket Format
2019-12-31 07:35:23 avtar Error <8609>: Connection killed from GSAN.
2019-12-31 07:35:23 avtar Info <9772>: Starting graceful (staged) termination, KILL event received (wrap-up stage)
2019-12-31 07:35:23 avtar FATAL <5704>: Fatal Server Error occurred (MSG_ERR_AUTH_FAIL), aborting execution (SECURETICKETLOGIN=452 serial=1 seq=0 flags=R:H:0 kind=0 rsp=MSG_ERR_AUTH_FAIL)
2019-12-31 07:35:23 avtar Error <5126>: Login error 5: Authorization failure (Session Ticket login)
2019-12-31 07:35:23 avtar FATAL <8941>: Fatal server connection problem, aborting initialization. Verify correct server address and login credentials.
2019-12-31 07:35:23 avtar Info <6149>: Error summary: 4 errors: 8941, 5704, 5126, 8609
2019-12-31 07:35:23 avtar Info <5917>: Back from run-at-end, exit code -1
2019-12-31 07:35:23 avtar Error <7001>: Exiting avtar with run-at-end script failure -1

 

Cause

GSANログを見ると、割り当てられたセッション チケットが以前のバックアップにすでに使用されている可能性があります。
これは、GSANまたはMCSのロールバックによってセッション チケットが順不同になったことで発生する可能性があります。

 

GSANログから

WARN: <1418> sessionkeytable::setpublickey session ticket with serial=28451 was used already
WARN: <1426> sessionkeytable::comparesignature incorrect signature

 

MCSのセッション チケットがGSANよりも大きい場合、GSANが遅れており、古いセッション チケットを使用してクライアントに提供していると推測できます。

診断に役立つ次のgrepコマンドを使用します。

grep -i "sessionkeytable\|minserial" /data01/cur/gsan.log.00?

 

Resolution

セッション チケットを再度同期する必要があります。

 

ステップ1:
現在のGSANのminserialを取得します。

avmaint cat /sysinfo/security/keytable

Example:

root@avamar:/home/admin/#: avmaint cat /sysinfo/security/keytable
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<keytable minimalserial="<minserial_less_than_mcs>">

 

ステップ2:
MCSから現在のセッション チケットのシリアル番号を取得します。

cat /usr/local/avamar/var/mc/server_data/prefs/sessionticket.srl

Example:

root@avamar:/home/admin/#: cat /usr/local/avamar/var/mc/server_data/prefs/sessionticket.srl
<mcs_session_ticket_larger_than_gsan>

 

ステップ3:
mcecroot」を使用し、avmaint と併用します。

cd /usr/local/avamar/lib

keytool -list -rfc -keystore /usr/local/avamar/lib/avamar_keystore -storepass `avlockbox.sh -r keystore_passphrase` -alias mcecroot | openssl x509 -pubkey -noout > mcecroot.pub

例:
このコマンドはkeytoolを使用して、 mcecroot エイリアスをavamar_keystoreに含め、結果をOpenSSLにパイプしてキーペアから公開キーを取得し、公開キーをmcecroot.pubというファイルに書き込みます。

root@avamar:/usr/local/avamar/lib/#: keytool -list -rfc -keystore /usr/local/avamar/lib/avamar_keystore -storepass `avlockbox.sh -r keystore_passphrase` -alias mcecroot | openssl x509 -pubkey -noout > mcecroot.pub

root@avamar:/usr/local/avamar/lib/#: cat mcecroot.pub
-----BEGIN PUBLIC KEY-----
MHYwEAYHKoZIzj0CAQYFK4EEACIDYgAEicGAqiHQQ8DRi0ZkgsvEA8fCEeqW/DIr
k53CFakwbOtTejb2Okk+2VTkY5H4gfLEKd4Gtq5gPP2OcpaUf/SrIc4MO3bn8OhC
l/vQKfAeJvrPPEvcIG0GiLyLtwJykeUq
-----END PUBLIC KEY-----

 

ステップ4:
を使用して、新しいGSANの最小シリアルを書き込みます。 mcecroot public keyを使用する場合は、MCSの現在の値よりも大きい数値を使用することを推奨します。

avmaint publickey --keyfile=./mcecroot.pub --serial=<your number> --ava

例:
次のエラーを回避するには、十分な高さのシリアル番号を選択する 必要があります

root@avamar:/usr/local/avamar/lib/#: avmaint publickey --keyfile=./mcecroot.pub --serial=28500 --ava
ERROR: avmaint: publickey: server_exception(MSG_ERR_INVALID_PARAMETERS)

root@avamar:/usr/local/avamar/lib/#: avmaint publickey --keyfile=./mcecroot.pub --serial=38000 --ava

無効なパラメーターのエラーが発生した場合は、エラーが発生しなくなるまで、より大きな数値を選択し続けます。

 

ステップ5:
変更を確認します。

avmaint cat /sysinfo/security/keytable

Example:

root@avamar:/usr/local/avamar/lib/#: avmaint cat /sysinfo/security/keytable
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<keytable minimalserial="38000">     <-- new gsan minserial
[..]

 

ステップ6:
その最小シリアルをMCSセッション チケットに書き込みます。

echo -n "<number you were able to use for mcec key>" > /usr/local/avamar/var/mc/server_data/prefs/sessionticket.srl

Example:

root@avamar:/usr/local/avamar/lib/#: echo -n "38000" > /usr/local/avamar/var/mc/server_data/prefs/sessionticket.srl

root@avamar:/usr/local/avamar/lib/#: cat /usr/local/avamar/var/mc/server_data/prefs/sessionticket.srl
38000

 

ステップ7:
MCSを再起動します。

mcserver.sh --restart

 

ステップ8:
テスト バックアップ。

 

Affected Products

Data Protection, Data Backup & Protection Software, Avamar, Avamar
Article Properties
Article Number: 000200098
Article Type: Solution
Last Modified: 06 Aug 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.