Das SSL-Zertifikat zeigt beim Durchsuchen einer Webserver-Benutzeroberfläche die Warnung "Ihre Verbindung ist nicht privat" an
Summary: Das SSL-Zertifikat zeigt beim Navigieren zu einer Webserver-Benutzeroberfläche die Warnung "Ihre Verbindung ist nicht privat" an.
Symptoms
Symptom: Das SSL-Zertifikat zeigt die Warnung "Ihre Verbindung ist nicht privat" an, wenn Sie auf der Benutzeroberfläche eines Webservers (Chrome-Browser) surfen.
Wenn Sie auf der linken Seite des Adressfelds des Browsers auf "Nicht sicher" klicken, werden die folgenden Warnhinweise angezeigt (Chrome-Browser).
Cause
- Das Zertifikat ist selbstsigniert.
- Der Clientbrowser vertraut dem CA-Zertifikat nicht
- Der FQDN, der Hostname oder die IP, die in das Adressfeld des Browsers eingegeben werden, stimmen mit keinem der Einträge in den alternativen Namen des Zertifikatantragstellers überein
Resolution
- Wenn ein Browser einen ungültigen Zertifikatfehler für ein selbstsigniertes Zertifikat anzeigt, bedeutet dies, dass das vom Server bereitgestellte Zertifikat nicht von einer vertrauenswürdigen Zertifizierungsstelle signiert wurde. Selbstsignierte Zertifikate werden nicht von einer vertrauenswürdigen Zertifizierungsstelle signiert, sondern von der Entität, die sie erzeugt hat.
Szenario #2: Intern von einer Zertifizierungsstelle signiertes Zertifikat.
- Wenn der Webbrowser den Fehler "ungültiges Zertifikat" für ein internes, von einer Zertifizierungsstelle signiertes Zertifikat anzeigt, kann dies daran liegen, dass das Zertifikat vom Browser nicht als vertrauenswürdig eingestuft wird.
Die genauen Schritte dazu hängen von Ihrem Browser und Betriebssystem ab. Hier sind einige allgemeine Schritte:
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Exportieren Sie das CA-Zertifikat von Ihrem internen CA-Server. Greifen Sie auf die Weboberfläche des CA-Servers zu, rufen Sie das CA-Zertifikat auf und exportieren Sie es dann in einem Format, das in Ihren Browser importiert werden kann.
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Importieren Sie das CA-Zertifikat in Ihren Browser. Öffnen Sie die Windows Systemsteuerung, wählen Sie Internetoptionen, Registerkarte Inhalt , klicken Sie unten auf Zertifikat und dann auf Vertrauenswürdige Stammzertifizierungsstellen. Klicken Sie auf Import , um das CA-Zertifikat in den vertrauenswürdigen Speicher zu importieren

Szenario #3: Das Zertifikat wurde von einer Drittanbieter-CA signiert.
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Wenn ein von einer CA eines Drittanbieters signiertes Zertifikat als ungültig angezeigt wird, kann dies verschiedene Gründe haben. Hier sind ein paar Dinge, die Sie überprüfen können:
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Ablaufdatum: Stellen Sie sicher, dass das Zertifikat weiterhin gültig und nicht abgelaufen ist. Überprüfen Sie das Ablaufdatum des Zertifikats, um sicherzustellen, dass es noch gültig ist.

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Zertifikatkette: Überprüfen Sie, ob die Zertifikatskette vollständig und korrekt auf dem Server installiert ist. Eine Zertifikatkette umfasst das SSL-Zertifikat, Zwischenzertifikate und das Stammzertifikat. Stellen Sie sicher, dass alle Zertifikate in der Kette gültig und korrekt installiert sind.

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Nicht übereinstimmender Domänenname: Stellen Sie sicher, dass der Domänenname auf dem Zertifikat (Alternativer Antragstellername) mit dem Domänennamen des Servers übereinstimmt, auf den Sie zugreifen möchten. Wenn eine Nichtübereinstimmung vorliegt, wird das Zertifikat als ungültig angezeigt.

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Widerruf des Zertifikats: Überprüfen Sie, ob das Zertifikat von der ausstellenden Zertifizierungsstelle widerrufen wurde. Ein widerrufenes Zertifikat wird als ungültig angezeigt.
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Zertifizierungsstelle: Stellen Sie sicher, dass die Zertifizierungsstelle, die das Zertifikat ausgestellt hat, von Ihrem Browser oder Gerät als vertrauenswürdig eingestuft wird. Wenn die Zertifizierungsstelle nicht vertrauenswürdig ist, wird das Zertifikat als ungültig angezeigt.
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Wenn nach der Überprüfung der oben genannten Punkte weiterhin Probleme auftreten, sollten Sie sich an das Supportteam der Zertifizierungsstelle wenden, die das Zertifikat ausgestellt hat, um weitere Unterstützung zu erhalten.