PowerStore: vVol SRM failover testing fails due to missing snapshot rule

Summary: This article addresses a situation where SRM failover testing fails when replicating vVols.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After configuring SRM for automated recovery for a vVol environment, a failover attempt fails with the following error in the SRM UI:
Cannot perform storage operation with vVol replication group <group_ID>
See the Recovery Plan steps below. The test fails at step 13: Change recovery site storage to writable 

screen shot of Recovery Plan steps, the test is failing at step 13: Change recovery site storage to writable

When reviewing the SRM logs, the following errors or warnings are reported:
 
SRC site SRM:
Cannot perform storage operation with vVol replication group '80c41884-5865-4d12-85dd-c71c6dd2a258:357f0ee1-3d5a-4aa9-86ad-990fb9d5a126'.
DR site SRM:
Cannot perform storage operation with vVol replication group '80c41884-5865-4d12-85dd-c71c6dd2a258:357f0ee1-3d5a-4aa9-86ad-990fb9d5a126'. com.vmware.vcDr.dr.vvolProvider.fault.ReplicationGroupFault Cause: MethodFault.summary com.vmware.sms.smsFault.locale
You may also see an error like this which indicates an issue with an invalid profile:
2023-06-20T17:40:09.693Z warning vmware-dr[04366] [SRM@6876 sub=DrI18nFilter opID=2759093b-6a50-4742-92e0-c64aff08cf73-retrieveRecoveryResult] [52b13] Localized message is missing for faultCause: (dr.vvolProvider.fault.ReplicationGroupFault) {
-->    faultCause = (sms.fault.InvalidProfile) {
-->       faultCause = (vmodl.MethodFault) null, 
-->       faultMessage = (vmodl.LocalizableMessage) [
-->          (vmodl.LocalizableMessage) {
-->             key = "com.vmware.sms.smsFault.locale", 
-->             arg = (vmodl.KeyAnyValue) [
-->                (vmodl.KeyAnyValue) {
-->                   key = "summary", 
-->                   value = "Profile is invalid or contains illegal combinations of capabilities."
 

Cause

When using SRM for recovery automation in a vVol environment, SRM relies on the Protection Policies set on each PowerStore.
The errors above indicate an issue with the Protection Policy being invalid and SRM cannot complete the failover when attempting to make the DR site snapshot writable.

In this instance, it was found that the Protection Policy on both PowerStore devices was missing a snapshot rule.
SRM failed because there was no snapshot to make writable during the failover test.

Resolution

Ensure the Protection Policy being used includes both a snapshot rule and replication rule.
Both the Source and Destination PowerStore must have the same Protection Policy assigned.

Affected Products

PowerStore
Article Properties
Article Number: 000215195
Article Type: Solution
Last Modified: 25 Jul 2025
Version:  4
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