Avamar: Resolving Invalid Password Issues After Upgrading to 19.10
Summary: After upgrading Avamar Server to version 19.10, backups and restores are failing with "Invalid Password" messages.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Instructions
Issue:
After upgrading Avamar Server to version 19.10, backups and restores are failing with "Invalid Password" messages similar to the following:
2016-04-18 14:12:07 avtar Error <5180>: Failed to retrieve backup list from account '/Test/testclient' (error code 69 MSG_ERR_PSWD_INVALID). 2016-04-18 14:12:07 avtar Error <5181>: Did you specify the account (--acnt) correctly? 2016-04-18 14:12:07 avtar Error <5184>: No matching backups found. Or 2016-04-18 12:13:21 avtar Error <8608>: Failed to complete backup; Authentication failure (Invalid password? User disabled?). (MSG_CMD_ACCESS_CHILD=47 serial=55 seq=0 flags=RU:N:0 kind=2 rsp=MSG_ERR_PSWD_INVALID retries=0) 2016-04-18 12:13:21 avtar Error <15085>: Backup not completed properly on server.
Cause:
This issue arises from cipher incompatibility between Avamar Server 19.10 and Client 19.8 when custom passwords are set forbackuponly, restoreonly, and backuprestore accounts. Per the Avamar 19.10 Best Practices Guide (page 13), all passwords should be changed except for the backuponly, restoreonly, and backuprestore accounts.
mcserver.xml file and the Avamar server database. The procedure to complete this task is detailed below.
Procedure:
Install GoAV:- For detailed information about this support tool, see article Avamar: GoAV tool on the Avamar server
- Ensure that the GoAV tool is at least at version 1.81 (though the latest version is recommended).
- Run the following GoAV Command to validate and fix account credentials:
./goav security fix-backup-account
Example Output:
Benefits of Using GoAV:
- Synchronizes account credentials with the updated standards
- Ensures that credentials remain valid even after applying hotfixes or upgrading the Avamar Server
- This eliminates the need for any manual intervention
Contact Support:
If unable to resolve with GoAV or installation is not permitted, contact Dell Support and reference this article 000223208 for assistance with the issue.
Article Properties
Article Number: 000223208
Article Type: How To
Last Modified: 11 Dec 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.