PowerStore: Import fails when an IP address is missing from the SSL certificate when adding Unity as a Remote System for File

Summary: PowerStore cannot add a Remote System if the Unity management IP address is absent from its self-signed certificate.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Error when trying to add Unity as a Remote System:
Failed to run REST request to the source Unity system because the specified IP address is not found in the SSL certificate of Unity. (0xE08010110DC4)

Screenshot from PowerStore Manager:
Failure screenshot

Cause

The Unity certificate is missing the "subjectAltName" information for the Unity management IP address and Fully Qualified Domain Name values.

Resolution

Generate a new certificate on Unity that specifies the "subjectAltName" information.

Example:
1) Using the openssl utility from a Linux host, create a Certificate Signing Request file with the following fields:
C=Country, ST=State, L=Location, O=Organization, CN=CommonName

service@Unity_LAB spb:~/user> openssl req -new -sha256 -key server.key -passin pass:emcemc -out request.csr -days 1825 -subj '/C=US/ST=MA/L=Sarasota/O=MyCust/CN=5.6.7.11/'

2) Self-sign the Certificate Signing Request file with the private key. If there is an "unable to write 'random state'" error, elevate to root user and try again.

service@Unity_LAB spb:~/user> openssl x509 -in request.csr -sha256 -out unitycer.crt -req -signkey server.key -days 1825 -extfile <(printf "subjectAltName=DNS:<MyUnity.LAB.DELL.COM>,DNS:<MyUnity>,IP:<IPV4  management IP>, IP:<IPV6 management IP>")

Affected Products

PowerStore
Article Properties
Article Number: 000226350
Article Type: Solution
Last Modified: 05 Sept 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.