「PowerStore:Unityをファイルのリモート システムとして追加するときにSSL証明書にIPアドレスがないとインポートが失敗する

Summary: 自己署名証明書にUnity管理IPアドレスがない場合、PowerStoreはリモート システムを追加できません。

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Symptoms

Unityをリモート システムとして追加しようとするとエラーが発生する:
Failed to run REST request to the source Unity system because the specified IP address is not found in the SSL certificate of Unity. (0xE08010110DC4)

PowerStore Managerのスクリーンショット:
失敗のスクリーンショット

Cause

Unity証明書に、Unity管理IPアドレスと完全修飾ドメイン名の値の「subjectAltName」情報がありません。

Resolution

「subjectAltName」情報を指定する新しい証明書をUnityで生成します。

例:
1) Using the openssl utility from a Linux host, create a Certificate Signing Request file with the following fields:
C=Country, ST=State, L=Location, O=Organization, CN=CommonName

service@Unity_LAB spb:~/user> openssl req -new -sha256 -key server.key -passin pass:emcemc -out request.csr -days 1825 -subj '/C=US/ST=MA/L=Sarasota/O=MyCust/CN=5.6.7.11/'

2) Self-sign the Certificate Signing Request file with the private key. If there is an "unable to write 'random state'" error, elevate to root user and try again.

service@Unity_LAB spb:~/user> openssl x509 -in request.csr -sha256 -out unitycer.crt -req -signkey server.key -days 1825 -extfile <(printf "subjectAltName=DNS:<MyUnity.LAB.DELL.COM>,DNS:<MyUnity>,IP:<IPV4  management IP>, IP:<IPV6 management IP>")

Affected Products

PowerStore
Article Properties
Article Number: 000226350
Article Type: Solution
Last Modified: 05 Sept 2025
Version:  2
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