IDPA: ACM muestra que la contraseña del usuario local no está sincronizada. Actualice la contraseña

Summary: En esta base de conocimientos, se explica cómo resolver el error "La contraseña del usuario local de Data Protection Central no está sincronizada. Actualice la contraseña", en ACM. Cuando ese error se debe a un problema de resolución de DNS en ACM y ACM no puede comunicarse con DPC. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La interfaz de usuario de ACM muestra que "Data Protection Central local user password is out of sync. Please update the password."

En el /usr/local/dataprotection/var/configmgr/server_data/logs/server.log, hay errores como los siguientes:

024-05-20 10:44:18,704 INFO  [https-openssl-apr-8543-exec-1]-util.SSHUtil: Processing the ssh command execution standard error.
2024-05-20 10:44:20,456 INFO  [https-openssl-apr-8543-exec-3]-util.SSHUtil: Processing the ssh command execution standard error.
2024-05-20 10:44:25,609 INFO  [https-openssl-apr-8543-exec-3]-util.SSHUtil: Processing the ssh command execution standard error.
...
2024-05-20 10:44:58,292 INFO  [Thread-430]-util.SSHUtil: Processing the ssh command execution standard error.
2024-05-20 10:44:58,388 ERROR [Thread-430]-util.RestUtil: Error occured while executing REST request. due to java.net.SocketException: Unexpected end of file from server
2024-05-20 10:44:58,388 ERROR [Thread-430]dpcadapter.DPCUtil: checkLocalUserOutOfSync-> DPC local user password is out of sync
        at org.glassfish.jersey.internal.Errors.process(Errors.java:315) ~[jersey-common-2.22.2.jar:?]
        at org.glassfish.jersey.internal.Errors.process(Errors.java:297) ~[jersey-common-2.22.2.jar:?]
        at org.glassfish.jersey.internal.Errors.process(Errors.java:228) ~[jersey-common-2.22.2.jar:?]
        at org.glassfish.jersey.internal.Errors.process(Errors.java:315) ~[jersey-common-2.22.2.jar:?]
        at org.glassfish.jersey.internal.Errors.process(Errors.java:297) ~[jersey-common-2.22.2.jar:?]
        at org.glassfish.jersey.internal.Errors.process(Errors.java:228) ~[jersey-common-2.22.2.jar:?]
2024-05-20 10:44:58,424 INFO  [Thread-427]-util.SSHUtil: Processing the ssh command execution standard error.
...
2024-05-20 10:44:58,358 INFO  [Thread-430]-dpcadapter.DPCUtil: getDPCHostname : getDPCHostname --->
2024-05-20 10:44:58,359 INFO  [Thread-430]-util.CommonUtil: hostname: XX.XXX.XXX.XXX ip: <hostname>
2024-05-20 10:44:58,359 INFO  [Thread-430]-dpcadapter.DPCUtil: Getting DPC Hostname -<hostname>
2024-05-20 10:44:58,359 INFO  [Thread-430]-util.RestUtil: Making REST call: https://<hostname>/elg/manage/info ,method: GET Meditype application/json
2024-05-20 10:44:58,388 ERROR [Thread-430]-util.RestUtil: Error occured while executing REST request. due to java.net.SocketException: Unexpected end of file from server
2024-05-20 10:44:58,388 ERROR [Thread-430]dpcadapter.DPCUtil: checkLocalUserOutOfSync-> DPC local user password is out of sync
com.emc.vcedpa.common.exception.ApplianceException: REST API execution failed.Not return expected response status.
        at com.emc.vcedpa.common.util.RestUtil.executeRestAPI(RestUtil.java:173) ~[vcedpa-common-2.7.6.jar:?]

Compruebe que el servidor DNS esté configurado. Ejecute el siguiente comando:

cat /etc/resolv.conf

Ejecute los siguientes comandos con la IP del primer "nameserver" enumerado en la salida anterior:

ping <nameserver IP>

curl -kv <nameserver IP>:53

Compruebe que ACM pueda resolver la dirección IP de DPC en un nombre de host:

host -W 10 -T <DPC IP>

Where <DPC IP> is the IP of the DPC server.

Cause

El comando host no devuelve el FQDN correcto para la dirección IP de DPC. Esto muestra que hay un problema con la resolución del nombre de host desde el entorno del cliente (su DNS externo) y es por eso que la llamada REST está fallando.

Resolution

Se requiere la resolución de nombres por DNS para los sistemas IDPA. 
Si la resolución de DNS falla, haga que el equipo de red del cliente solucione este problema. 
Una vez que se resuelve la resolución de DNS, ACM puede conectarse a DPC y se resuelve este problema.  

Additional Information

Affected Products

PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Software, PowerProtect DD6400, PowerProtect DP5900 , PowerProtect DP8400 ...

Products

PowerProtect DP8900
Article Properties
Article Number: 000228626
Article Type: Solution
Last Modified: 01 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.