Avamar: VM restore to a new VM fails with error "vSphere Task failed: 'File vmname.vmdk is larger than the maximum size supported by datastore"
Summary: After initiating a VMware image restore job, it fails after nearly 2 minutes, with the following error message: "vSphere Task failed: 'File vmname.vmdk is larger than the maximum size supported by datastore 'datastore-name' " ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- In restore logs, the following error messages can be observed:
avvcbimage Error <44035>: vSphere Task failed: 'File [datastore-name] vm-name/vm-name.vmdk is larger than the maximum size supported by datastore 'datastore-name''. avvcbimage Error <44020>: VM '[datastore-name] vm-name/vm-name.vmx' reconfigure task creation encountered a problem avvcbimage Error <0000>: [IMG2012] VM creation failed during restore.
- The same error message can be seen on "Recent Tasks" pane on vSphere UI.
- A new VM is created on vCenter, but is left over after restore failure with no data attached, and 0 B disk sizes
Cause
The target datastore is configured with a maximum size of virtual disk that can be created. It will not allow creation of virtual disks bigger than that limit.
Example: Below datastore is configured with a maximum size of 2 TB for creating virtual disks. That means virtual disks with a size of more than or equal to 2 TB cannot be created. Thus, restore fails because vSphere prevents Avamar from creating a disk of that size or bigger.
Example: Below datastore is configured with a maximum size of 2 TB for creating virtual disks. That means virtual disks with a size of more than or equal to 2 TB cannot be created. Thus, restore fails because vSphere prevents Avamar from creating a disk of that size or bigger.
Resolution
Restore the VM to another datastore that has a bigger virtual disk size limit.
Affected Products
Avamar Client for VMwareProducts
AvamarArticle Properties
Article Number: 000230168
Article Type: Solution
Last Modified: 11 Dec 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.