L'interfaccia utente del gateway PowerFlex 3.X non si apre, viene visualizzato un errore 404
Summary: L'interfaccia utente di PowerFlex 3.x non è accessibile; viene visualizzato un errore 404 quando si tenta di aprirla. PowerFlex 3.x è raggiungibile dalla CLI.
Symptoms
L'interfaccia utente del gateway PowerFlex è diventata inaccessibile, tuttavia il gateway era raggiungibile dalla CLI.
L'interfaccia utente del gateway PowerFlex restituisce l'errore:
HTTP Status 404 - Not Found Type Status Report Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists. Apache Tomcat/8.5.65

Cause
La root cause è che il file /opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties non è in un buon formato. Ci sono parti mancanti, in questo caso nella parte inferiore.
Resolution
Analizzati i registri e il file in /opt/emc/scaleio/gateway e ho scoperto che il file /opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties è stato danneggiato.
Al file mancano alcune parti nella parte inferiore:

Questo file deve essere ripristinato da un backup o confrontandolo con un file simile di un altro cluster.
Al termine dell'operazione, riavviare il servizio gateway:
#systemctl restart scaleio-gateway
Articolo correlato:
Consultare l'articolo Errore 404 visto dal gateway PowerFlex in cui viene descritto un problema simile a questo file che causa anche un errore 404.