Avamar:從 Swagger UI 建立 OAuth2 用戶端失敗,並出現未經授權的錯誤
Summary: 無法在 Avamar 版本 19.7 中從 Swagger UI 建立 OAuth2 使用者,導致未經授權的錯誤。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
客戶從 Swagger UI 建立 OAuth2 使用者時發生問題。
- 客戶無法從 Swagger UI 建立 OAuth2 使用者,導致嘗試失敗。
- 客戶正在尋找一種解決方案,可以在不使用命令列的情況下,從 Swagger UI 建立 OAuth2 使用者。
curl -k \ -H "Content-Type:application/json" \ -H 'authorization:Basic cm9vdDpOQUxBLVN1cHAwcnQtMDAw' \ -X POST -d '{"accessTokenValiditySeconds": 1800, "authorizedGrantTypes": ["password"], "autoApproveScopes": ["all" ], "clientId": "felixtest", "clientName": "felixtest", "clientSecret": "changeme", "redirectUris": [ "https://my-app-server/callback" ], "refreshTokenValiditySeconds": 43200, "scopes": ["read", "write"]}' \ https://10.241.170.119/api/v1/oauth2/clients
客戶已提供以下步驟來重現此問題:
- 使用 MCUer 登入 Swagger UI。
- 將 Swagger UI 中的其他功能使用權杖,例如列出活動和用戶端。
- 嘗試使用 Swagger UI 建立新的 OAuth2 用戶端。
- 請注意,OAuth2 用戶端的創建失敗。
Cause
問題的根本原因與使用 Swagger UI 建立 OAuth2 用戶端時的驗證程序有關。
- 此問題與任何環境變更或系統組態無關,而是對驗證程序的誤解。
- 此問題的根本原因是錯誤的假設,即OAuth2用戶端可以在沒有正確身份驗證的情況下使用Swagger UI創建。
Resolution
從 Swagger UI 建立 OAuth2 使用者失敗的問題的解決方案涉及瞭解正確的身份驗證過程以及創建 OAuth2 用戶端所需的最低許可權。
- 首先,確保嘗試創建 OAuth2 用戶端的使用者具有正確的身份驗證憑據。管理員指南提到使用管理員憑據,特別是 MCUser 帳戶。
- 從 Swagger UI 建立 OAuth2 用戶端時,應在開始時不授權 Swagger UI 的情況下執行後調用。在執行後通話期間,提供憑據並登錄。
- 若要在 oauth2-client 控制器下執行其他 API 呼叫,請先使用正確的登入資料授權 Swagger UI,然後再觸發這些呼叫。
- 使用不同的角色進行測試,以確認只有管理員角色才能創建 OAuth2 用戶端。管理員指南中提到了這一點。
- 使用下列步驟,從 Swagger UI 建立 OAuth2 用戶端:
- 開啟 Swagger UI 並瀏覽至 oauth2-client 控制器。
- 按一下「 Create OAuth2 Client」 按鈕
- 輸入所需的詳細資訊,例如用戶端名稱、用戶端 ID、用戶端密碼和重定向 URI。
- 按一下「Execute」按鈕以建立 OAuth2 用戶端
- 通過檢查 Swagger UI 回應來驗證是否已成功創建 OAuth2 用戶端。
- 如果問題仍然存在,請檢查 rest API 記錄是否有任何錯誤或問題。
- 請參閱 Avamar 說明文件和管理員指南,以取得建立 OAuth2 用戶端和所需最低權限的進一步資訊。
警示:如果您不確定任何步驟或有任何疑慮, 請聯絡 Dell 支援 以取得協助。
Additional Information
欲瞭解更多資訊,請查看 Jira https://jira.cec.lab.emc.com/browse/AVAMARESC-2460。
Affected Products
Avamar ServerArticle Properties
Article Number: 000240375
Article Type: Solution
Last Modified: 10 Jan 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.