PowerProtect Data Manager: 에이전트 플러그인 등록이 실패하고 "프록시에 연결할 수 없음" 오류 발생

Summary: PowerProtect Data Manager 에이전트 플러그인이 "프록시에 연결할 수 없음" 오류로 인해 등록에 실패합니다.

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Symptoms

증상에 대한 세부 정보가 여기에 표시되고 따라야 할 항목이 있는 경우 아래 로그에 표시됩니다.


OpAgentSvc.log에는 다음과 같은 오류 메시지가 표시됩니다.

Traceback (most recent call last):
File "Http\HTTPServer.py", line 5524, in sendCSR
File "requests\api.py", line 115, in post
File "requests\api.py", line 59, in request
File "requests\sessions.py", line 587, in request
File "requests\sessions.py", line 701, in send
File "requests\adapters.py", line 559, in send
requests.exceptions.ProxyError: HTTPSConnectionPool(host='gcpppdmdb01.hhcsystem.org', port=8443): Max retries exceeded with url: /api/v2/adm/agentRegistration (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed: 403 Forbidden')))
[2025-01-08 19:00:39,777 GMT| 2025-01-08 14:00:39,777047 Eastern Standard Time| DBGHTTPSERVER| PID-21584| TID-6244| INFO] C:\Program Files\DPSAPPS\AgentService\tmp\_MEI138882\Http\HTTPServer.pyc-sendCSR()-Line 5534- Remediation : Send CSR request failed. The PowerProtect Data Manager server is not accessible.

Cause

시스템을 확인하고 프록시 사용을 위해 시스템 변수가 정의되었는지 확인합니다.

set | findstr /I proxy

HTTPS_PROXYHTTP_PROXY가 정의된 경우 프록시를 우회하도록 NO_PROXY 환경 변수를 정의해야 합니다.

HTTPS_PROXY 및 HTTP_PROXY가 정의되었지만 NO_PROXY가 정의되지 않은 경우 프록시에 연결할 수 없음과 함께 PPDM 에이전트 플러그인 등록이 실패할 수 있습니다. 오류.

Resolution

NO_PROXY 환경 변수는 프록시 서버를 우회해야 하는 주소 또는 정규화된 도메인 이름으로 정의되어야 합니다.

Windows 환경 변수 NO_PROXY 영구적으로 설정하려면 다음을 수행합니다. 

  • 시작 메뉴를 열고 환경 변수를 검색합니다.   
  • 시스템 환경 변수 편집 을 선택합니다.   
  • 시스템 속성 창에서 환경 변수를 클릭합니다.   
  • 사용자 변수 또는 시스템 변수에서 새로 만들기를 클릭합니다.   
  • 변수 이름으로NO_PROXY를 추가하고 변수 값으로 쉼표로 구분된 도메인 또는 주소 목록을 추가합니다(예: PPDM_FDQN,DD_FQDN,IP_of_PPDM,IP_of_DD).   
  • OK를 클릭하여 저장합니다.

PPDM 에이전트 서비스를 재시작하고 등록을 다시 시도합니다.

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000276524
Article Type: Solution
Last Modified: 28 Jan 2025
Version:  1
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