PowerProtect Data Manager:エージェント プラグインの登録が「プロキシに接続できません」で失敗する

Summary: PowerProtect Data Managerエージェント プラグインが「プロキシに接続できません」というエラーで登録に失敗します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

ここに表示される症状の詳細と、従うべき項目がある場合は、以下のログに表示されます。


OpAgentSvc.logに次のエラー メッセージが表示されます。

Traceback (most recent call last):
File "Http\HTTPServer.py", line 5524, in sendCSR
File "requests\api.py", line 115, in post
File "requests\api.py", line 59, in request
File "requests\sessions.py", line 587, in request
File "requests\sessions.py", line 701, in send
File "requests\adapters.py", line 559, in send
requests.exceptions.ProxyError: HTTPSConnectionPool(host='gcpppdmdb01.hhcsystem.org', port=8443): Max retries exceeded with url: /api/v2/adm/agentRegistration (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed: 403 Forbidden')))
[2025-01-08 19:00:39,777 GMT| 2025-01-08 14:00:39,777047 Eastern Standard Time| DBGHTTPSERVER| PID-21584| TID-6244| INFO] C:\Program Files\DPSAPPS\AgentService\tmp\_MEI138882\Http\HTTPServer.pyc-sendCSR()-Line 5534- Remediation : Send CSR request failed. The PowerProtect Data Manager server is not accessible.

Cause

システムをチェックし、システム変数がプロキシ用に定義されていることを確認します。

set | findstr /I proxy

HTTPS_PROXYHTTP_PROXYが定義されている場合は、プロキシをバイパスするNO_PROXY環境変数を定義する必要があります。

HTTPS_PROXYとHTTP_PROXYが定義されているが、NO_PROXY定義されていない場合、PPDMエージェント プラグインの登録が失敗し、プロキシに接続できない可能性があります。エラー。

Resolution

NO_PROXY環境変数は、プロキシー・サーバーをバイパスする必要があるアドレスまたは完全修飾ドメイン名を使用して定義する必要があります。

Windows環境変数 NO_PROXY 永続的にセットアップするには、次の手順を実行します。 

  • [スタート]メニューを開き、[ 環境変数]を検索します。   
  • システム環境変数 の編集 を選択します。   
  • システムのプロパティウィンドウで、 環境変数をクリックします。   
  • 「ユーザー変数」または「システム変数」で、「 新規」をクリックします。   
  • NO_PROXYを変数として追加し、ドメインまたはアドレスのコンマ区切りリストを変数値として追加します(例:PPDM_FDQN,DD_FQDN,IP_of_PPDM,IP_of_DD)。   
  • [OK]をクリックして保存します。

PPDMエージェント サービスを再起動して、登録を再試行します。

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000276524
Article Type: Solution
Last Modified: 28 Jan 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.