Avamar: File restore fails with error "Unable to BackupWrite"

Summary: File restore fails with error "Unable to BackupWrite" due to insufficient permissions of the local SYSTEM account to write to the specified folder.

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Symptoms

Restore Failure Error.

The restore of files using Windows File System plug-in may fail and produce the error below:

  • Restore operation fails 
  • Error message is displayed
avtar Error <5737>: I/O error: Unable to BackupWrite(4)

Cause

Insufficient Permissions

The account configured for the avagent (Backup Agent) service does not have sufficient permissions to write to the specified folder.

By default, the avagent service runs with the local SYSTEM account, which lacks the necessary read/write access to the destination folder and subfolders.

This permission issue is shown in this error message:

Error <5737>: I/O error: Unable to BackupWrite(4)

 

Resolution

Restoring File Backup Functionality

To resolve the issue, grant the local SYSTEM account read/write access to the destination folder and subfolders. This can be achieved by modifying the folder permissions.

Follow these steps to adjust the permissions:

  • Locate the destination folder in Windows Explorer.
  • Right-click the folder and select Properties.
  • In the Properties window, go to the Security tab.
  • Click Edit to change permissions.
  • In the Permissions window, click Add.
  • Enter "SYSTEM" in the Enter the object names to select field and click Check Names.
  • Once the SYSTEM account is added, select it and check the boxes for Read and Write permissions.
  • Click Apply and then OK to save the changes.

Alternatively, configure the Backup Agent service to run with a domain user account with at least read/write privileges to the destination folder.

  1. Configure Avamar Services:

    • Open the Services management console (services.msc).
    • Locate the Avamar Backup Agent service.
    • Right-click the service and select Properties.
    • Go to the Log On tab.
    • Select This account and enter the domain user credentials (username and password).
    • Click Apply and then OK.
  2. Restart the Service: Go back to the General tab and click Start to restart the service.

    After updating the permissions, verify that the issue is resolved by attempting to restore files using the Windows File System plug-in.

    If issues persist, contact Dell Support for assistance.

    Affected Products

    Avamar Client for Windows

    Products

    Avamar, Avamar Client
    Article Properties
    Article Number: 000030795
    Article Type: Solution
    Last Modified: 20 May 2025
    Version:  4
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