DPA: Agent fails to start when not using Local System Account

Summary: Data Protection Advisor (DPA) agent fails to start when using a Named Windows account instead of the Local System Account; missing Logon as Service privilege and folder rights cause logon failure. ...

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Symptoms



While attempting to collect from Microsoft SQL Server via DPA Agent which was configured to use a Named Account instead of Local System Account for Windows Authentication the following problems were seen:
  • DPA Agent fails to start with to  unable to start due logon failure  error
  • The dpaagent logs and the files under agent\data folder were not updated

Cause

The Named Account used for the DPA Agent was not configure with all the required privileges 

Resolution

The Named Account used for the DPA Agent will need the additional privileges in order to run correctly:
  1. Grant  Logon as Service  privilege to the Named Account
  2. Update permissions on agent install folder to grant the Named Account Full Control
Please contact Dell EMC Technical Support for further details or information.

Affected Products

App Direct File System Agent
Article Properties
Article Number: 000071464
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  4
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