PowerProtect Data Manager:Exchange 備份失敗,並出現初始化錯誤

Summary: PowerProtect Data Manager:Exchange 備份失敗,並顯示「初始化錯誤 -- 無法初始化 Exchange shell」

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

在應用程式代理程式記錄或匯出工作記錄中,出現下列錯誤:

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]145370:msagentsv: 

Initialization error -- Unable to initialize Exchange shell. Required for 

Exchange.
VERBOSE: 
VERBOSE: 2022-12-09T03:30:32.420Z 

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]202816:msagentsv: Unable to

 query Exchange for DAG information when checking for a DAG backup. An 

exception occurred.
VERBOSE: 2022-12-09T03:30:32.425Z 

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]203192:msagentsv: Exception

 occurred in save program: 'Unable to process command line arguments.' .
VERBOSE: 
VERBOSE: 2022-12-09T03:30:32.426Z 

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]102333:msagentsv: Exiting 

with failure.


開啟新的 Exchange PowerShell,查看它是否正確連線至 Active Directory。

Cause

  1. 設定的使用者帳戶沒有必要的權限 (請查看 Exchange 使用者指南)。
  2. 已安裝其他備份軟體 (例如 Avamar 用戶端或 NetWorker 用戶端)。
 

Resolution

  1. 若未正確設定 AppAgent Exchange 管理員組態工具的管理員使用者,請以管理員角色授予備份帳戶存取權限。
  2. 解除安裝其他備份軟體 (例如 Avamar 或 NetWorker),然後將主機重新開機。

Affected Products

PowerProtect Software
Article Properties
Article Number: 000211377
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  3
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