PowerProtect Data Manager: Errore del motore di ricerca con cluster non operativo
Summary: Errore del motore di ricerca PowerProtect Data Manager dopo il deployment con il messaggio "Cluster is not operational. Il servizio API non è in esecuzione sul nodo:" Lo stato del motore di ricerca è pronto. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Il motore di ricerca PowerProtect Data Manager (PPDM) si interrompe dopo il deployment con il seguente messaggio.
Il cluster non è operativo. Il servizio API non è in esecuzione sul nodo:" Lo stato del motore di ricerca è pronto.
Il seguente errore chiave viene visualizzato nel registro VMDM:
2023-03-13T06:48:55.138Z ERROR [Timer-1] [][][][][] [c.e.b.v.v.s.h.SearchUpdateHelper.getSearchTelemetry(352)] - Failed to get telemetry data
com.emc.brs.vmdm.error.ComponentException: org.springframework.web.client.HttpClientErrorException$Unauthorized: 401 Unauthorized: "The user does not have authorization to access this API<EOL>The user does not have authorization to access this API<EOL>"
Cause
"L'utente non dispone dell'autorizzazione per accedere a questa API"
Questo messaggio indica che il nodo di ricerca non è in grado di risolvere il nome di dominio completo PPDM. Non è in grado di comunicare con l'istanza PPDM.
Questo messaggio indica che il nodo di ricerca non è in grado di risolvere il nome di dominio completo PPDM. Non è in grado di comunicare con l'istanza PPDM.
Resolution
Verificare la presenza di problemi DNS:
- Accedere al nodo di ricerca
- Eseguire una ricerca del nome di dominio completo dell'istanza PPDM. nslookup <Nome di dominio completo di PPDM
- La ricerca dovrebbe essere risolta correttamente. Se la risoluzione non riesce, si verifica un problema con il DNS fornito quando è configurato il nodo di ricerca. In alternativa, potrebbe essersi verificata una modifica nella configurazione DNS. Se questa è la configurazione iniziale del nodo di ricerca, correggere il valore DNS e riconfigurarlo.
In caso contrario, aggiungere il server PPDM alla voce DNS del server DNS, una volta configurato il nodo di ricerca.
Passaggi per recuperare le credenziali del nodo di ricerca:
- Nell'appliance PPDM, passare all'utente root.
- Eseguire i seguenti comandi.
source /opt/emc/vmdirect/unit/vmdirect.env
/opt/emc/vmdirect/bin/infranodemgmt get --secret
Affected Products
PowerProtect SoftwareArticle Properties
Article Number: 000211378
Article Type: Solution
Last Modified: 18 Sept 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.