NetWorker: nsrazure_recover fejler "Mål-VM skal allerede eksistere for en enkelt diskgendannelse."

Summary: Kommandoen nsrazure_recover bruges til at gendanne et snapshot af Azure Virtual Machine (VM), der blev sikkerhedskopieret ved hjælp af NetWorker. Kommandoen mislykkes næsten øjeblikkeligt og rapporterer "Mål-VM skal allerede eksistere for en enkelt diskgendannelse." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

azure-nve:~ # nsrazure_recover -S 4154256312 -N 'Azure' -R 'NW-PERF' -A 'networkerstorageaccount' -V 'Test-VM' -E 'NW-PERF:vnet' -T 'subnet'
207830:nsrazure_recover: Response Code: 404 Response Data: {"error":{"code":"ResourceNotFound","message":"The Resource 'Microsoft.Compute/virtualMachines/Test-VM' under resource group 'NW-PERF' was not found. For more details please go to https://aka.ms/ARMResourceNotFoundFix"}}

207974:nsrazure_recover: Target VM must already exist for a single disk recovery.

Cause

SSID (Save Set ID), der er angivet i nsrazure_recover kommandoen er for en DataDisk, ikke en OsDisk. Den VM, der er angivet med -V VM_NAME er til en ny VM, ikke en eksisterende VM.

azure-nve:~ # mminfo -avot
volume        type   client           date     time         size ssid      fl   lvl name
….
azure_nve.local.dddefault.003 Data Domain azure-nve.local 08/13/25 15:47:03 31 GB 4171033528 cb full NW-PERF:azure-ubuntu:azure-ubuntu_OsDisk_1_cf93159d6205414baa8593901a918d3a
azure_nve.local.dddefault.003 Data Domain azure-nve.local 08/13/25 15:47:04 33 GB 4154256312 cb full NW-PERF:azure-ubuntu:azure-ubuntu_DataDisk_0

Det er ikke muligt at foretage en DataDisk gendannelse til en ny VM. En eksisterende VM skal angives.

Dette forventes funktionalitet.

Resolution

  • Valgmulighed et: Hvis du kun vil gendanne datadisken, skal du angive -V Existing_VM I nsrazure_recover kommando.
  • Mulighed to: Hvis du vil gendanne VM'en til en ny VM, skal du angive et SSID for VM'erne OsDisk:
azure-nve:~ # mminfo -avot
volume        type   client           date     time         size ssid      fl   lvl name
….
azure_nve.local.dddefault.003 Data Domain azure-nve.local 08/13/25 15:47:03 31 GB 4171033528 cb full NW-PERF:azure-ubuntu:azure-ubuntu_OsDisk_1_cf93159d6205414baa8593901a918d3a
azure_nve.local.dddefault.003 Data Domain azure-nve.local 08/13/25 15:47:04 33 GB 4154256312 cb full NW-PERF:azure-ubuntu:azure-ubuntu_DataDisk_0

azure-nve:~ # nsrazure_recover -S 4171033528 -N 'Azure' -R 'NW-PERF' -A 'networkerstorageaccount' -V 'TestVM' -E 'DD-PERF:vnet' -T 'subnet'
Using 'vnet' vnet from resource group 'NW-PERF'.
Target VM 'NW-PERF:TestVM' does not exist and will be recreated.
Restoring OS disk 'azure-ubuntu_OsDisk_1_cf93159d6205414baa8593901a918d3a'.
Using 'networkerstorageaccount' storage account from resource group 'NW-PERF'.
… 

Additional Information

I nogle scenarier kan en disk vises som "OsDisk_JobID_TimeStamp" for eksempel:

azure-nve:~ # mminfo -avot
volume        type   client           date     time         size ssid      fl   lvl name
….
azure_nve.local.dddefault.003 Data Domain azure-nve.local 08/13/25 15:47:03 31 GB 4171033528 cb full NW-PERF:azure-ubuntu:azure-ubuntu_OsDisk_0_17143_1751393058

Denne disk antyder, at den blev oprettet fra et tidligere gendannelsesforsøg. I løbet af en nsrazure_recover, behandles det som en DataDisk, ikke en OsDisk. I løbet af nsrazure_recover, skal du angive SSID for en OS-disk, der ikke er tilføjet med en JobId_TimeStamp:

azure-nve:~ # mminfo -avot
volume        type   client           date     time         size ssid      fl   lvl name
….
azure_nve.local.dddefault.003 Data Domain azure-nve.local 08/13/25 15:47:03 31 GB 4171033528 cb full NW-PERF:azure-ubuntu:azure-ubuntu_OsDisk_1_cf93159d6205414baa8593901a918d3a

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000356781
Article Type: Solution
Last Modified: 14 Aug 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.