NMC: Reports Fail to Generate, "The connection attempt failed"
Summary: Generating any report from the NetWorker Management Console (NMC) Reports tab fails. A message appears stating "the connection attempt failed."
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Symptoms
All NetWorker Management Console (NMC) Reports fail to generate. An error appears stating "The connection attempt failed."
Cause
Port 5432 is not open or is being blocked between the NMC client and NetWorker/NMC server. See: NetWorker Processes and Ports
NOTE: The "NMC client" refers to the host used to connect to the NetWorker Management Console.
Resolution
1. On the NMC server, confirm that port 5432 is listening:
nsrports -t localhost -p 5432
Example:
2. On the NMC client, confirm that port 5432 is reachable on the NMC server host:
Windows PowerShell command:
tnc NMC_SERVER_HOSTNAME -p 5432
Example:
NOTE: Any name resolution errors reported must be resolved. Create a local hosts file entry on the NMC server to resolve its hostname. Alternatively, consult the domain administrator to fix name resolution. NetWorker: Name Resolution Troubleshooting Best Practices. If port 5432 fails to connect, check the NMC server’s firewall settings. Consult documentation or the system administrator to confirm it is not being blocked. If no operating system firewall rules are enabled/set to block port 5432, consult with your network or security administrator to resolve any port connection issues.
Once the port is open, the connection to port 5432 from the NMC client host should report as successful:
Once the port 5432 connection between the NMC client and NMC server, close and relaunch the NMC. NMC Reports should generate correctly now.
Affected Products
NetWorkerProducts
NetWorker Family, NetWorker Management ConsoleArticle Properties
Article Number: 000038109
Article Type: Solution
Last Modified: 06 Nov 2025
Version: 6
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