Avamar:証明書とキーが一致しない場合にプラグインベースのレプリケーションが失敗する
Summary: 証明書とキーが一致しない場合、プラグインベースのレプリケーションは失敗します。
Symptoms
次のいずれかの症状が観察されることがあります。
1.ポリシー ベースのレプリケーションの構成中に、UIで別のAvamarグリッドをレプリケーション デスティネーションとして追加すると、[認証の確認]が失敗します。
2.ポリシー ベースのレプリケーションの実行に失敗します。ログには、次のエラー メッセージが表示される場合があります。
avagent Info <5008>: Logging to /usr/local/avamar/var/client/MOD-1476725811111-1008-Replicate-avagent.log
avagent Info <19803>: Ignoring the --service flag.
avagent Info <5702>: Command Line: /usr/local/avamar/bin/avagent.bin --gencerts="true" --mcsaddr="targetgrid.avamar.com" --mcsport="28001" --conntimeout="120" --logfile="/usr/local/avamar/var/client/MOD-1476725811111-1008-Replicate-avagent.log" --debug="false" --sysdir="/usr/local/avamar/etc/client"
avagent Info <5703>: Parsed Flags: /usr/local/avamar/bin/avagent.bin --gencerts=true --mcsaddr=targetgrid.avamar.com --mcsport=28001 --conntimeout=120 --logfile=/usr/local/avamar/var/client/MOD-1476725811111-1008-Replicate-avagent.log --debug=false --sysdir=/usr/local/avamar/etc/client
[avagent] ERROR: <0001> sslcontext::loadCert certificate/key not found or invalid cert=/usr/local/avamar/etc/client/10.1.2.3/cert.pem key=/usr/local/avamar/etc/client/10.1.2.3/key.pem
avagent Error <5664>: SSL certificate/key not found or invalid.
avagent Info <0000>: Checking for stale certificate lock
Cause
Avamar 7.3以降では、ポリシー ベースのレプリケーションにより、ソース サーバーとターゲット サーバー間のSSL接続用の証明書が生成されます。ソース ユーティリティー ノードには、レプリケーション ターゲットごとにフォルダーが作成されます。
/usr/local/avamar/etc/client/<replication target>
例: /usr/local/avamar/etc/client/10.10.10.2
- レプリケーション ジョブが実行されるたび。
- UIで[Verify Authentication]が選択されるたび。
ただし、状況によっては、Avamarが既存のファイルを上書きしないため、cert.pemとkey.pemの不一致が発生し、レプリケーションが失敗します。
Resolution
1.次の手順を実行して、証明書とキーの不整合が問題であることを確認します。
ある。Avamarユーティリティー ノードにadminとしてログインします。
b.root権限への昇格:
su -
c. 次のコマンドを使用して、証明書とキーのペアを保存するフォルダを特定します。
ls -l /usr/local/avamar/etc/ | grep ^d
drwx------ 2 root root 4096 Aug 22 13:28 10.10.10.2
drwx------ 2 root root 4096 Aug 22 13:28 192.168.76.50
drwxr-xr-x 2 admin admin 4096 Apr 21 10:37 admin
drwxr-xr-x 2 admin admin 4096 Jun 25 09:09 akm
drwxr-xr-x 2 admin admin 4096 Apr 21 10:37 avi
drwxr-xr-x 3 admin admin 4096 Jun 25 09:22 client
drwxr-xr-x 2 admin admin 4096 Apr 21 10:37 dtlt
drwxr-xr-x 5 root root 4096 Jun 13 02:37 gsan-maint-scripts
drwxr-xr-x 2 admin admin 4096 Apr 21 10:37 mcs
drwxr-xr-x 2 admin admin 4096 Apr 21 10:37 server
上記の出力には、レプリケーション ターゲット グリッドの IP アドレスを持つフォルダーがあるはずです。
レプリケーション ターゲットが複数ある場合は、複数のフォルダーがあります。ここに示すように、レプリケーション パートナーは10.10.1.2と192.168.76.50です。
この記事では、192.168.76.50を例として使用します。
d. 次のものがあることを確認します cert.pem と key.pem ファイル:
ls -l /usr/local/avamar/etc/192.168.76.50/*.pem
出力例:
-rw-r--r-- 1 root root 2248 Jun 13 08:55 /usr/local/avamar/etc/192.168.76.50/cert.pem
-rw-r--r-- 1 root root 1793 Jun 13 14:21 /usr/local/avamar/etc/192.168.76.50/chain.pem
-rw-r--r-- 1 root root 2484 Jun 13 08:55 /usr/local/avamar/etc/192.168.76.50/key.pem
e.証明書とキーを確認します。
openssl x509 -noout -modulus -in /usr/local/avamar/etc/192.168.76.50/cert.pem | openssl md5
(stdin)= 2ba9eb24b22a0158ea4366e1971ad915
openssl rsa -noout -modulus -in /usr/local/avamar/etc/192.168.76.50/key.pem
(stdin)= b342ae5f5e044bbd8aff7d2dfb698bd3
f.上記の2つの値が一致しない場合、問題は確認済みです。
2.不整合が確認されたら、次の手順を実行して古い証明書を削除し、新しい証明書とキーを作成します。
古い証明書とキーを削除します。
ある。Avamarユーティリティー ノードにadminとしてログインします。
b.root権限への昇格:
su -
c. 元の証明書をバックアップするディレクトリを作成します。
mkdir /tmp/certificatebackup
d. 証明書とキーを含むディレクトリをバックアップします。
cp -p /usr/local/avamar/etc/192.168.76.50/* /tmp/certificatebackup/
e.古い証明書を削除します。
rm -f /usr/local/avamar/etc/192.168.76.50/*
f.証明書が削除されていることを確認します。
ls -l /usr/local/avamar/etc/192.168.76.50
total 0
新しい証明書とキーを生成します。
MCS UI:
ある。Avamar Administrator MCS UIで、[Data Movement Policy]ランチャーを選択します。
b.[Destinations]タブを選択します。
c. 必要な宛先を強調表示します。
d. 右クリックして[Edit Destination]を選択します。
e.変更を加えずに、[Verify Authentication]をクリックします。
検証が成功した場合は、手順3に進みます。検証に失敗した場合は、 デル・テクノロジーズAvamarサポートにお問い合わせください 。
AUI:
ある。AUIで[System]を選択します。
b.[System]で[Replication Destination]ランチャーを選択します。
c. 必要な宛先に関連付けられたラジオボタンを選択します。
d. 「編集」をクリックします。
e.認証情報を入力します。
f. [Validate]をクリックします。
検証が成功した場合は、手順3に進みます。検証に失敗した場合は、デル・テクノロジーズAvamarサポートにお問い合わせください 。
3.レプリケーションを再試行して、問題が解決されたことを確認します。
問題が解決しない場合は、Avamar SCRチームと協力してスウォームを作成し、支援を受けてください。