Avamar: "Konsolenserverdaten konnten nicht auf dem Server gespeichert werden" aufgrund von Portscannern, die eine hohe Java-CPU-Auslastung verursachen

Summary: Port-Scanner verursachen eine hohe Java-CPU-Auslastung, was zu einem MCS-Leerungsfehler (Management Console Server) führt: "Konsolenserverdaten konnten nicht auf dem Server gespeichert werden." ...

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Symptoms

Dieses Ereignis kann als Dial-Home-Ereignis oder MC-UI-Ereignis protokolliert oder in einer PuTTY-Sitzung auf dem Avamar Utility Node angezeigt werden:

Symptom: 22402, Desc: Could not save console server data to server.
 

Der Java-Prozess auf dem Avamar Utility Node ist bei 100 % CPU oder höher:

top
top - 10:57:10 up 140 days, 19:57,  2 users,  load average: 2.55, 2.52, 2.48
Tasks: 187 total,   1 running, 186 sleeping,   0 stopped,   0 zombie
Cpu(s): 74.5%us,  0.2%sy,  0.0%ni, 25.4%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:     12028M total,    10789M used,     1238M free,      187M buffers
Swap:     4086M total,       68M used,     4018M free,     7507M cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
12108 admin     20   0 1720m 1.3g  11m S  299 10.9 112556:00 java
13476 admin     20   0 1125m 541m  11m S    0  4.5 157:08.53 java
14055 root      20   0 1485m 158m  10m S    0  1.3 184:58.50 java
 

Einer oder mehrere der folgenden Fehler werden in der /usr/local/avamar/var/mc/server_log/axis2.logaus:

2013-01-24 23:01:42,517 [1031746922@qtp-1453087591-170] ERROR org.apache.axis2.engine.AxisEngine  - The service cannot be found for the endpoint reference (EPR) /php.cgi?/etc/passwd
org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) /php.cgi?/etc/passwd
        at org.apache.axis2.engine.DispatchPhase.checkPostConditions(DispatchPhase.java:65)
        at org.apache.axis2.engine.Phase.invoke(Phase.java:334)

2014-04-09 12:44:56,908 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcService-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcService-server-7.0.0-SNAPSHOT.jar
2014-04-09 12:44:59,015 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcsdk10-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcsdk10-server-7.0.0-SNAPSHOT.jar

Cause

Eine hohe Java-Auslastung auf dem Avamar Utility Node-Node kann dazu führen, dass die Leerungen (Backups) des Management Console Server (MCS) fehlschlagen.

Eine Steigerung der konstanten CPU-Auslastung nach Portscans sendet Garbage Query-Zeichenfolgen über Port 9443 an den MC-Webservice.

Infolgedessen ist der MCS für den Backupprozess nicht verfügbar und kann dazu führen, dass die Leerung fehlschlägt.

 

Resolution

1. Überprüfen Sie, ob ein Port-Scanner (z. B. Nessus) scannt einen der Avamar-Nodes. Deaktivieren Sie nach Möglichkeit das Scannen von Ports auf den Avamar Utility Node.

2. Melden Sie sich beim Avamar Utility Node als Administrator an und laden Sie die Avamar-Schlüssel: So melden Sie sich bei einem Avamar-Server an und laden verschiedene Schlüssel.

3. Verwenden Sie den Befehl top Befehl zum Überprüfen, ob Java eine hohe CPU-Auslastung hat (über 100 % ist hoch):

top

 

 

4. Überprüfen Sie, ob Port-9443-Meldungen im Achsenprotokoll angezeigt werden:

grep 9443 /usr/local/avamar/var/mc/server_log/axis2.log
2014-04-09 12:44:56,908 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcService-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcService-server-7.0.0-SNAPSHOT.jar
2014-04-09 12:44:59,015 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcsdk10-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcsdk10-server-7.0.0-SNAPSHOT.jar
 

5. Überprüfen Sie, wann der Java-Prozess gestartet wurde:

ps -ef | grep java

 

    • Wenn das Datum des Java-Prozesses mit den Daten aus Schritt 4 übereinstimmt (in diesem Beispiel 2014-04-09), befindet sich der Prozess möglicherweise in einem nicht reagierenden Zustand
    • Wenn das Datum des Java-Prozesses neu ist oder nicht übereinstimmt, beenden Sie die Verwendung dieser Lösung.

6. Wechseln Sie zur Root-Berechtigung:

su - 

 

 

7. Beenden Sie den fehlerhaften Java-Prozess:

ein. Suchen Sie die Java-Prozess-ID (PID):

ps -ef | grep java
 

b. Beenden Sie den Prozess.

kill -9 <PID>
 

8. Beenden Sie das Root-Recht:

exit
 

9. Beenden und starten Sie MCS mit Avamar: So starten Sie den Management Control Server (MCS) neu

10. Überprüfen Sie, ob die MCS-Leerung jetzt funktioniert und keine "22402"-Fehler auftreten.

mcserver.sh --flush
 

11. Wenn die Fehlermeldungen weiterhin angezeigt werden, lesen Sie Avamar – Symptomcode 22402 – Daten des Konsolenservers konnten nicht auf dem Server gespeichert werden (Lösungspfad) für zusätzliches Troubleshooting.

Wenn weitere Unterstützung erforderlich ist, erstellen Sie einen Service-Request.

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000163004
Article Type: Solution
Last Modified: 23 Sept 2025
Version:  8
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