PowerFlex:VMの電源投入に失敗するエラー「一般的なシステム エラーが発生しました:vDSホスト エラー」

Summary: この記事では、仮想マシン(VM)エラーのトラブルシューティングと修正について説明します。一般的なシステム エラーが発生しました:vDSホスト エラー

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

仮想マシン(VM)の電源投入が次のエラーで失敗する:
A general system error occurred: vDS host error

または 

A general system error occurred: vDS host error: see faultCause Cannot create DVPort ### of VDS <DISTRIBUTED SWITCH NAME> on the host <hostname.example.com>

 

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x
vSphere ESXi 7.x
vSphere ESXi 8.x
VCF 9.0 

 

Cause

この問題は、特定のVM仮想ネットワーク インターフェイス カード(NIC)のデータベース レコードが正しくないために発生します
 

Resolution

この問題を解決するには、仮想NICを再度追加して、VMのクリーンなデータベース レコードを作成します。

注意:この手順は、vSphereのみの環境にのみ有効です。VM仮想NICを再追加すると、次のようなアドオン製品を使用する際に予期しない問題が発生する可能性があります。

  • vRealize Automation
  • 水平線ビュー
  • vCloudディレクタ
  • VMware Integrated OpenStack

他の製品がvCenter Serverに追加されているかどうか不明な場合は、この手順を実行しないでください。

  1. vCenterホストおよびクラスター ビューでVMオブジェクトを検索します。
  2. VMを右クリックし、[Edit Settings...]を選択します。
  3. すべての仮想NIC設定をメモしておきます。
  4. 仮想NICを削除します。
メモ: VMに複数の仮想NICがある場合は、一度に1つの仮想NICのみを削除します。vCloud Director を使用している場合は、ネットワーク インターフェイスの削除を参照してください。
  1. 変更を保存します。
  2. VMをもう一度右クリックし、Edit Settings...を選択します。
  3. 同じ設定を使用して仮想NICを再度追加します。

VMに複数の仮想NICがあり、それでも電源がオンにならない場合は、次の仮想NICに対して手順1〜7を使用します。
 

注: 

NICを削除して再度追加する手順に従う前に、VM上のポート グループも変更し、電源をオンにしてから元の状態に戻すことで、問題が解決する場合があります。

**VMに割り当てられた元のポートグループをメモしておき、VMが再び起動して実行されたら、このポートグループに戻してください。 

Additional Information

影響/リスク:
次のようなVMwareアドオン製品を使用している場合は、VM仮想NICの削除と読み取りは行わないでください

  • vRealize Automation
  • 水平線ビュー
  • vCloudディレクタ
  • VMware Integrated OpenStack

仮想マシンをパワーオンできませんでした

 

 

「エラー: 一般的なシステム エラーが発生しました。vDSホスト エラー」で、仮想マシンの電源投入中にエラーが発生しました 

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000384370
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.