PowerFlex: VM 전원 켜기 실패 오류 일반 시스템 오류 발생: vDS 호스트 오류

Summary: 이 문서에서는 VM(가상 머신) 오류 문제 해결 및 수정에 대한 정보를 제공합니다. 일반 시스템 오류 발생: vDS 호스트 오류

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

다음 오류와 함께 VM(Virtual Machine)의 전원을 켤 수 없습니다.
A general system error occurred: vDS host error

또는 

A general system error occurred: vDS host error: see faultCause Cannot create DVPort ### of VDS <DISTRIBUTED SWITCH NAME> on the host <hostname.example.com>

 

환경

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x
vSphere ESXi 7.x
vSphere ESXi 8.x
재질 보기 VCF 9.0 

 

Cause

이 문제는 특정 VM 가상 NIC(네트워크 인터페이스 카드)에 대한 잘못된 데이터베이스 레코드로 인해 발생합니다
 

Resolution

이 문제를 해결하려면 가상 NIC를 다시 추가하여 VM에 대한 깨끗한 데이터베이스 레코드를 만듭니다.

주의: 이 절차는 vSphere 전용 환경에만 유효합니다. VM 가상 NIC를 다시 추가하면 다음과 같은 추가 기능 제품을 사용할 때 예기치 않은 문제가 발생할 수 있습니다.

  • vRealize 자동화
  • Horizon View
  • vCloud 디렉터
  • VMware 통합 OpenStack

vCenter Server에 다른 제품이 추가되었는지 확실하지 않은 경우 이 절차를 수행하지 마십시오.

  1. vCenter 호스트 및 클러스터 보기에서 VM 개체를 찾습니다.
  2. VM을 마우스 오른쪽 버튼으로 클릭하고 Edit Settings...를 선택합니다.
  3. 모든 가상 NIC 설정을 기록해 둡니다.
  4. 가상 NIC를 삭제합니다.
참고: VM에 가상 NIC가 두 개 이상 있는 경우 한 번에 하나의 가상 NIC만 제거합니다. vCloud Director를 사용하는 경우 네트워크 인터페이스 제거의 내용을 참조하십시오.
  1. 변경 사항을 저장합니다.
  2. VM을 다시 마우스 오른쪽 버튼으로 클릭하고 Edit Settings...를 선택합니다.
  3. 동일한 설정을 사용하여 가상 NIC를 다시 추가합니다.

VM에 둘 이상의 가상 NIC가 있지만 여전히 전원이 켜지지 않는 경우 다음 가상 NIC에 대해 1-7단계를 사용합니다.
 

참고: 

NIC를 제거하고 다시 추가하는 다음 단계를 수행하기 전에 VM의 포트 그룹을 변경하고 전원을 켠 다음 원래대로 다시 변경하여 문제를 해결할 수 있습니다.

**VM에 할당된 원래 포트 그룹을 기록해 두었다가 VM이 다시 실행되면 이 포트 그룹으로 다시 변경하십시오. 

Additional Information

영향/위험:
다음과 같은 VMware 추가 기능 제품을 사용하는 경우 VM 가상 NIC를 제거한 다음 다시 추가해서는 됩니다.

  • vRealize 자동화
  • Horizon View
  • vCloud 디렉터
  • VMware 통합 OpenStack

가상 머신의 전원을 켜지 못했습니다.

 

 

자세한 내용은 "오류: A general system error occurred: vDS host error" running on a virtual machine 

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000384370
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.