NetWorker: il License Server restituisce un errore dovuto alla modifica del nome host

Summary: Il License Server NetWorker restituisce un errore dovuto alla modifica del nome host.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il nome host del License Server è stato modificato

NetWorker Management Console (NMC)

Sul server NetWorker, avviare la finestra Administration di NMC, cliccare con il pulsante destro del mouse sul server, quindi scegliere Properties dall'elenco. Nella scheda Licensing della finestra Server Properties individuare e selezionare il file di licenza per popolare il campo di testo della licenza CLP .

Durante la convalida del file di licenza da NMC viene visualizzato il seguente errore:
 

Checking CLP connection using '/nsr/lic/licspec.properties'.
Checking license properties file '/nsr/lic/licspec.properties'
Found 'license.path=/nsr/lic/_NETWV_3651067_06-Oct-2018.lic'
Checking license file '/nsr/lic/_NETWV_3651067_06-Oct-2018.lic'
157364:nsrlic: Unable to check out 'NETWORKER_UPDATE': status = -16 'Cannot read data from license server system. (-16,287)'
157364:nsrlic: Unable to check out 'NETWORKER_CAPACITY': status = -16 'Cannot read data from license server system. (-16,287)'
157363:nsrlic: License file '/nsr/lic/_NETWV_3651067_06-Oct-2018.lic' issues found: 0
FAILED
 
La colonna lmgrd Il servizio è in esecuzione, ma l'errore viene ancora visualizzato "Cannot read data from license server system"

Cause

NetWorker Server era connesso al vecchio License Server.
Il nome host del License Server è stato modificato.
Le porte 27000 e 27001 non sono state aperte.

Resolution

  1. Ucciso il lmgrd Servizio
  2. Start lmgrd servizio e leggere il file di licenza
[root@emc]# lmutil lmreread -c /opt/emc/licenses
lmutil - Copyright (c) 1989-2014 Flexera Software LLC. All Rights Reserved.
lmreread successful
  1. Controllare la connettività tra il License Server e il NetWorker Server. nslookup e ping funziona bene, ma quando controlliamo la porta il suo fallimento sul server delle licenze
[root@emclicenseserver]# curl -kv hostname:27001
* About to connect() to hostname port 27001 (#0)
* Trying 10.33.16.154... Connection refused
* couldn't connect to host
  1. Aprire le porte 27000 e 27001 a livello di sistema operativo
  2. Aggiornare il nome del License Server come specificato nel file di licenza in nsradmin Poiché ha un vecchio nome del server licenze e l'utente ha modificato il nome host
nsradmin> p type: nsr
type: NSR;
name:hostname;
version: \
NetWorker 9.1.1.5.Build.288 CLP Capacity License;
comment: ;
CLP License server: oldlichostname;
CLP License server port: 27000;

refresh license conformance report: No;
nsradmin> update CLP License server: newlichostname
CLP License server: newlichostname;
Update? y
updated resource id 3.0.118.14.163.194.113.75.0.0.0.0.10.33.16.151(8147)
nsradmin> p type: nsr
type: NSR;
name: hostname;
version: \
NetWorker 9.1.1.5.Build.288 CLP Capacity License;
comment: ;
CLP License server: newlichostname;
CLP License server port: 27000;

refresh license conformance report: No;
  1. Riavviare il server NetWorker
  2. Dalla finestra Administration di NMC -> cliccare sul nome del server -> server Properties ->scheda Licensing -> Cliccare sul testo della licenza CLP per sfogliare il file di licenza -> cliccare su ok. Sfogliare il file e verificare se è stato convalidato correttamente.

Affected Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000044563
Article Type: Solution
Last Modified: 10 Mar 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.