SourceOne Email Management - Échec de la mise à niveau des bases de données SourceOne

Summary: La mise à niveau de la base de données SourceOne n’a pas pu être effectuée lors de la mise à jour de SourceOne vers une version supérieure.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



La mise à niveau des bases de données SourceOne échoue lors de la mise à jour de SourceOne vers une version supérieure. 
Impossible de mettre à niveau la base de données en exécutant le fichier ES1_ActivityDB_Update_mssql.bat, car SQLCMD ne fonctionnait pas, ce qui entraînait une erreur de la base de données lors de l’exécution du script de mise à niveau.

Sqlcmd : Error: Échec de connexion.
SQL Native Client n’est pas installé correctement. Pour corriger cela, exécutez le programme d’installation de SQL Server.

Cause

Le chemin d’accès au dossier BIN du serveur SQL Server était incorrect ou manquant.

Resolution

Corrigez ou ajoutez le chemin d’accès au dossier bin SQLCMD comme suit.

Dans les propriétés du système :> Paramètres avancés du système - Avancé ->> Variables d’environnement -> Sélectionnez Chemin à partir des variables système.
Modifiez le chemin comme emplacement de SQLCMD, c’est-à-dire C :\Program Files\Microsoft SQL Server\110\Tools\Binn\

En attribuant le chemin correct du SQLCMD au dossier Path, la base de données peut alors être connectée et la mise à niveau peut se poursuivre.

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000051898
Article Type: Solution
Last Modified: 04 Jun 2026
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.