VNX: Unisphere Service Manager (USM) failure due to a reported error with the message: Insufficient permission to run CLI (Customer Correctable)

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Symptoms



An attempt to apply a VNX system code upgrade via Unisphere Service Manager (USM) results in a Pre-upgrade Health Check (PUHC) wizard failure and an error is reported with the following message.

Error message: Insufficient permission to run CLI command

Cause

  • Global user (sysadmin) is mapped to a user on the Control Station with a different name, usually sysadmin# (ex. sysadmin1, sysadmin2, etc..)
  • This is common whenever a Unisphere domain re-join occurs
  • The CS user home directory is not present

Example:

# ls -la /var/tmp/ | grep -i cut
drwxrwxrwx  5 sysadmin3 nasadmin   4096 Jan 20 16:45 .CUT <<< CS user via which the upgrade through USM is to be applied 

# cat /etc/passwd | grep -i sysadmin
sysadmin:x:500:201::/home/sysadmin:/sbin/nologin
sysadmin1:x:501:201::/home/sysadmin1:/sbin/nologin
sysadmin2:x:502:201::/home/sysadmin2:/sbin/nologin
sysadmin3:x:503:201::/home/sysadmin3:/bin/bash   <<<< user: sysadmin3

# ls -la /home/ | grep -i sysadmin
drwx------  2       574 nasadmin     4096 Dec 13  2013 sysadmin
drwx------  3 sysadmin1 nasadmin     4096 Dec 23 09:56 sysadmin1
drwxr-xr-x  2 sysadmin2 nasadmin     4096 Jan 20 09:22 sysadmin2 

Notice that sysadmin3 does not have a /home directory

Resolution

In order to address this issue, a sysadmin /home directory should be created manually and the appropriate files should be present within the directory
  • Login to the Control Station via SSH as root
  • Run the following commands,
$ mkdir /home/sysadmin<Number>
$ cp /home/sysadmin/.bash* /home/sysadmin# 

After the creation of the /home/sysadmin# directory and copying the .bash* files into it, re-log into USM and apply the upgrade procedure

Additional Information

KBA # 000427047 discusses several symptoms that might cause the same error message

Affected Products

VNX/VNXe

Products

VNX/VNXe
Article Properties
Article Number: 000057229
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  4
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