Avamar. Сбой Browse Isilon после ввода пароля, не отображается каталог «/ifs»

Summary: Пользовательский интерфейс Avamar не может просматривать Isilon; После ввода пароля «/ifs» не отображается. Причина: отсутствует или неправильно настроен пользователь протокола управления сетевыми данными (NDMP). Убедитесь, что пользователь NDMP существует, запустите avsetupndmp и введите пароль NDMP. /ifs можно просматривать. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При просмотре Isilon из пользовательского интерфейса Avamar обнаружена проблема.

Симптомы, о которых сообщают пользователи, включают:

  • После ввода пароля обзора /ifs каталог не отображается в пользовательском интерфейсе Avamar.  
  • Сообщения об ошибках или предупреждения не отображаются.
  • Проблема возникает при новой установке с конфигурацией по умолчанию.
  • Выполняется
avsetupndmp
  • Нажатие кнопки «Edit» на узле ускорителя приводит к тому, что клиент не проходит аутентификацию пользователя NDMP.

Cause

Лежащая в основе неправильная конфигурация, приводящая к сбою просмотра.
Пользователь NDMP не создан или у него отсутствуют разрешения


Avamar Accelerator пытается аутентифицироваться в Isilon с помощью пользователя NDMP. Если пользователь NDMP не существует или не обладает необходимыми разрешениями, проверка подлинности завершается сбоем, что приводит к прекращению ответа операции обзора после ввода пароля.

  • Пользователь NDMP отсутствует в конфигурации Isilon
  • Существующему пользователю NDMP не хватает прав для выполнения заданий NDMP
  • Введен неправильный или несоответствующий пароль NDMP в avsetupndmp
# isi ndmp user ls
NDMP User
---------
ndmpebadmin
 

Протокол NDMP не включен в Isilon.

Если служба NDMP отключена в пользовательском интерфейсе Isilon, ускоритель не может установить сеанс NDMP, что приводит к сбою аутентификации и отсутствию /ifs Представление каталога.

  • Флажок службы NDMP снят в пользовательском интерфейсе> Isilon Протоколзащиты данных>
  • Порт NDMP не прослушивает (по умолчанию 10000)
# isi ndmp settings global view
ndmp port 10000
dma: generic


Ошибки

конфигурации пароляИспользование неверного пароля для пользователя NDMP или учетной записи администратора Avamar Browse препятствует успешной проверке подлинности, что приводит к наблюдаемой недоступности.

  • Введенный пароль NDMP не совпадает с паролем, заданным для пользователя NDMP в Isilon
  • Пароль администратора обзора не синхронизирован с учетными данными Isilon

Resolution

Восстановление просмотра Isilon в пользовательском интерфейсе Avamar.

Предварительные условия

  • Доступ администратора к кластеру Isilon (root)
  • Доступ администратора к узлу ускорителя Avamar
  • Сетевое подключение между узлом ускорителя и IP-адресом управления Isilon.

Пошаговое решение

  1. Убедитесь, что служба NDMP включена в Isilon:
В пользовательском интерфейсе Isilon перейдите в раздел Data Protection>Protocols NDMP> и убедитесь, что  NDMP Этот флажок установлен. Если внесены изменения, нажмите кнопку Сохранить.
  1. Убедитесь, что пользователь NDMP существует:
# telnet  23
login: root
Password: ********

# isi ndmp user ls
 
В выходных данных должен быть указан пользователь, например ndmpebadmin. Если пользователь не отображается, создайте его (см. шаг 5).
  1. Проверьте доступ по протоколу HTTP к пространству имен Isilon:
В узле Accelerator запустите команду curl с использованием NDMP или root верительные грамоты:
curl -vk -u "root" -X GET 'https://:8080/namespace/ifs'

Список каталогов в формате JSON или XML указывает на то, что служба доступна.

  1. Проверьте глобальные параметры NDMP:
# isi ndmp settings global view

Убедитесь, что отображается вывод ndmp port 10000 и dma: generic . При необходимости выполните корректировку с помощью пользовательского интерфейса Isilon.

  1. Создайте авторизованного пользователя NDMP (если он отсутствует):
# isi ndmp user create ndmp --password
Введите пароль при появлении запроса.  
  1. Настройте клиент NDMP на ускорителе Avamar.
Запустите утилиту настройки NDMP и измените конфигурацию клиента:
# avsetupndmp

При появлении запроса:
Если утилита уже ожидает ввода пароля, введите пароль NDMP и нажмите клавишу Enter.

  • Примите настройки по умолчанию вплоть до запроса пароля NDMP.
  • Введите пароль, созданный для пользователя NDMP на шаге 5.
  1. Обзор клиента Isilon в Avamar.
Откройте Avamar Administrator UI >Backup & Restore>.    Выберите клиент Isilon и убедитесь, что /ifs отобразится и может быть расширена.


Проверка

  • Успешный curl возвращает список каталогов для /ifs
  • В пользовательском интерфейсе Avamar отображается /ifs root и позволяет переходить во вложенные каталоги
  • При просмотре веб-страниц или во время бега сообщения об ошибках не отображаются avsetupndmp 
Внимание! Все команды в Isilon должны выполняться с привилегиями root. Неправильное использование может привести к нарушению работы служб кластера.

Внимание! Изменение пользователей или параметров NDMP может повлиять на существующие задания резервного копирования NDMP. Убедитесь, что другие расписания резервного копирования по-прежнему работают после внесения изменений.

Примечание. Если после выполнения указанных выше действий проблема не устранена, соберите avsetupndmp журналы и обратитесь в службу поддержки Dell , чтобы получить файлы журналов и описание выполненных действий.

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000064571
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.