Авамар: Не вдається переглянути Isilon після введення пароля, немає відображення каталогу "/ifs"
Summary: Інтерфейс користувача Avamar не може переглядати Isilon; Після введення пароля "/ifs" не відображається. Причина: відсутній або неправильно налаштований користувач протоколу керування мережними даними (NDMP). Переконайтеся, що користувач NDMP існує, запустіть avsetupndmp і введіть пароль NDMP; /ifs можна переглянути. ...
Symptoms
Проблема спостерігається під час перегляду Isilon з інтерфейсу користувача Avamar.
Симптоми, про які повідомляють користувачі, включають:
- Після введення пароля перегляду,
/ifsкаталог не відображається в інтерфейсі користувача Avamar. - Повідомлення про помилки та попередження не відображаються.
- Проблема виникає під час нової інсталяції з конфігурацією за замовчуванням.
- Біг
avsetupndmp
- Вибір редагування на вузлі Accelerator призводить до того, що клієнт не може пройти автентифікацію користувача NDMP.
Cause
Неправильна конфігурація, що призводить до збою перегляду.
Користувач NDMP не створений або не має дозволів
Прискорювач Avamar намагається автентифікуватися в Isilon за допомогою користувача NDMP. Якщо користувач NDMP не існує або не має потрібних дозволів, автентифікація не виконується, що призводить до припинення відповіді після введення пароля.
- Користувач NDMP відсутній у конфігурації Isilon
- Існуючий користувач NDMP не має дозволу на виконання завдань NDMP
- Неправильний або невідповідний пароль NDMP введено в
avsetupndmp
# isi ndmp user ls NDMP User --------- ndmpebadmin
Протокол NDMP не ввімкнено на Isilon.
Якщо в інтерфейсі користувача Isilon вимкнуто службу NDMP, корисна можливість не зможе встановити сеанс NDMP, що призведе до помилки автентифікації та відсутності /ifs Перегляд каталогу.
- Пункт перевірки служби NDMP знімається в інтерфейсі> користувача Isilon Протокол захисту даних>
- Порт NDMP не слухає (за замовчуванням 10000)
# isi ndmp settings global view ndmp port 10000 dma: generic
Помилки
конфігурації пароляВикористання неправильного пароля для користувача NDMP або облікового запису адміністратора Avamar browse запобігає успішній автентифікації, що призводить до спостережуваної недоступності.
- Введений пароль NDMP не збігається з паролем, встановленим для користувача NDMP на Isilon
- Пароль адміністратора перегляду не синхронізується з обліковими даними Isilon
Resolution
Відновіть перегляд Isilon в інтерфейсі користувача Avamar.
Передумови
- Доступ адміністратора до кластера Isilon (root)
- Доступ адміністратора до вузла Avamar Accelerator
- Мережеве з'єднання між вузлом Accelerator та IP управління Isilon.
Покрокове вирішення
- Переконайтеся, що на Isilon увімкнено службу NDMP:
NDMP Встановлено прапорець. Натисніть «Зберегти», якщо ви внесли зміни.
- Переконайтеся, що користувач NDMP існує:
# telnet 23 login: root Password: ******** # isi ndmp user ls
У виводі має бути вказано користувача, наприклад
ndmpebadmin. Якщо користувач не відображається, створіть його (див. крок 5).
- Перевірте HTTP-доступ до простору імен Isilon:
curl запит за допомогою NDMP або root Облікові дані:
curl -vk -u "root" -X GET 'https://:8080/namespace/ifs'
Список каталогів JSON або XML вказує на те, що служба доступна.
- Перевірте глобальні налаштування NDMP:
# isi ndmp settings global view
Переконайтеся, що на виході відображається ndmp port 10000 і dma: generic . За потреби відрегулюйте за допомогою інтерфейсу користувача Isilon.
- Створіть авторизованого користувачем NDMP (якщо він відсутній):
# isi ndmp user create ndmp --password
- Налаштуйте клієнт NDMP на Avamar Accelerator:
# avsetupndmp
Коли з'явиться
запит: Якщо утиліта вже чекає на пароль, введіть пароль NDMP і натисніть Enter.
- Прийміть налаштування за замовчуванням аж до запиту пароля NDMP.
- Введіть пароль, створений для користувача NDMP на кроці 5.
- Перегляньте клієнт Isilon в Avamar:
/ifs Каталог відображається і може бути розширений.
Верифікація
- Успішний
curlзапит повертає список каталогів для/ifs - Інтерфейс Avamar показує
/ifsroot і дозволяє здійснювати навігацію по підкаталогах - Повідомлення про помилки не з'являються під час перегляду веб-сторінок або під час роботи
avsetupndmp
Обережність: Зміна користувачів або параметрів NDMP може вплинути на наявні завдання резервного копіювання NDMP. Переконайтеся, що інші розклади резервного копіювання все ще працюють після змін.
Примітка: Якщо після виконання наведених вище кроків проблема не зникає, зберіть
avsetupndmp журналів і зв'яжіться зі службою підтримки Dell з файлами журналу та описом виконаних дій.