Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

How to Troubleshoot Multiple Monitor Issues

Summary: Learn how to troubleshoot multiple monitor issues. Find information about common troubleshooting steps to resolve display issues when using multiple monitors.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  

Learn how to troubleshoot display issues like monitor not detected, no display error message, when using multiple monitors connected to the computer.

  • Laptop not detecting the monitor.
  • Computer not detecting second monitor or multiple monitors.
  • Second monitor or multiple monitors not displaying.
  • Windows is not detecting the second monitor or multiple monitors.

If you are trying to setup multiple monitors, see the Dell knowledge base article:

Cause

Multiple monitor issues might be caused due to faulty video cables, incorrect settings on the monitor or incorrect settings in Windows, outdated video drivers.

Resolution

It is essential to verify if the problem is inherent with the monitor, video card (GPU) or video settings on your personal computer. A straightforward way to identify this is to connect the personal computer to a known-good external monitor or TV and ensure that the display (S-video, VGA, DVI, HDMI, or DisplayPort) cables are firmly connected to the video ports on the personal computer and the monitor.

To learn more about connecting your Dell personal computer to a monitor or TV, see the Dell knowledge-base article How to Connect a Monitor to a Dell Computer.

Performance issues may occur if there is any type of damage that is caused to the display cables or the LCD screen. LCD screen may show that symptoms like LCD screen stop working, work intermittently, color mismatch, flickering, display horizontal or vertical lines, so forth if there is a damage to the display cables or the LCD screen.

If you do notice a physical damage, contact Dell Technical Support to learn more about repair options that are available in your region. If there is no damage, go to the next step.

Dell monitors provide a self-test feature check (STFC) and an integrated self-test (BIST) diagnostic tool that helps determine if the screen abnormality you are experiencing is an inherent problem with the Dell monitor or with the video card (GPU) and personal computer settings.

When you notice screen abnormalities like flickering, distortion, clarity issues, fuzzy or blurry image, horizontal or vertical lines, color fade, it is always a good practice to isolate the monitor by running a diagnostic check on the Dell monitor.

To learn more about running a diagnostic check on your Dell monitor, see the Dell knowledge-base article How to Run a Diagnostic Test on a Dell Monitor.

NOTE: Self-test feature check (STFC) helps check if the Dell monitor is functioning normally as a stand-alone device. To check for screen abnormalities like flickering, distortion, clarity issues, fuzzy or blurry image, horizontal or vertical lines, color fade.
 
NOTE: Integrated self-test (BIST) can be run only when one or more video cables are unplugged and the Dell monitor is in self-test mode.

To reset a Dell monitor to factory default settings, follow these instructions:

  1. Press Button 3 on the monitor to enter the On-Screen Display (OSD) Menu.
  2. Press Button 1 or Button 2 to select Others option in the menu and press Button 3 to select.
  3. Press Button 1 or Button 2 to select Factory Reset option in the menu and press Button 3 to select.
  4. Press Button 3 to confirm the reset action.
NOTE: The reset instructions for your Dell monitor might vary, see the documentation of your Dell monitor for model-specific instructions.

Dell recommends updating the device drivers and BIOS as part of your scheduled update cycle. These device drivers and BIOS updates may contain feature enhancements or changes that will help keep your system software current and compatible with other computer modules (hardware and software) as well as increased stability.

It is essential to update the following device drivers for optimal video performance and to resolve common video issues:

  • BIOS
  • Chipset driver
  • Video Card (GPU) driver
  • Monitor driver

To learn more about downloading and installing a device driver on a Dell personal computer, see the Dell knowledge-base article How to Download and Install Dell Drivers.

Windows updates can support your Windows operating system in many ways. Windows updates can solve specific problems, provide protection from malicious attacks, or even add new features to the operating system.

How to run Windows Updates on Microsoft Windows 11 or Windows 10?

  1. Right-click Start and click Settings.
  2. In the Settings panel, click Update & Security.
  3. In the left panel, select Windows Update.
  4. On the right panel, click Check for updates.
  5. Restart the personal computer after downloading and installing the updates.

Display settings like refresh rate, resolution, and power management may affect the performance of your Dell monitor. Changing the display settings can help resolve several types of video issues.

To learn more about changing the brightness, refresh rate and resolution on a Dell personal computer, see the Dell knowledge-base article How to Change the Video Settings or Improve Text in Windows 11 and Windows 10.

System Restore is an integrated Windows tool that is designed to protect and repair the operating system. When something goes wrong with your personal computer, System Restore should be used prior to restoring the personal computer to factory defaults.

Learn How to Use System Restore in Microsoft Windows.

Additional Information

Frequently asked questions

  • Microsoft Windows 11
  • Microsoft Windows 10
  • Microsoft Windows 8 or 8.1
  • Microsoft Windows 7

For the best experience, it is recommended to have multiple monitors of the same specification (monitor size and maximum supported resolution). You may connect monitors of different size and resolution if to an available video port on the personal computer.

Most laptop PCs support one external monitor that can be connected to an available video port (VGA, DVI, HDMI, or DisplayPort). See the User Manual of your personal computer to learn how many multiple monitors it can support simultaneously.

Docking stations or port replicators allow you to connect multiple monitors and other devices to the personal computer.

NOTE: Some laptop PCs may only allow the laptop LCD to be the primary monitor.

Yes, you can connect a TV to the personal computer as a secondary monitor. The video port or connector on your personal computer must match with an available video port or connector on the TV. While most TVs come with HDMI, some TVs also support VGA connectivity to a personal computer.

Yes, you will still be able to use them in a multiple monitor setup. However, both monitors will work in their individual supported resolution and one monitor may be bigger or smaller in size than the other.

For the best viewing experience, it is recommended to have monitors of the same specifications.

Microsoft Windows 11 and Windows 10 by default supports multiple monitor configurations. Windows 11 and Windows 10 can extend the ‘Taskbar’ to all the connected monitors by default with full Windows menu integration.

There are four display modes available in Microsoft Windows 10, which can be accessed by pressing Windows logo + P key on the keyboard.

NOTE: Display mode shortcut Windows logo + P key can be used in Windows 11, Windows 10, Windows 8 or 8.1 and Windows 7 operating systems.
  • Personal Computer Screen only: Windows will only use your primary monitor, and any additional monitors will be black.
  • Duplicate: Windows will show the same image on all monitors. This is useful if you are giving a presentation and want the same image on your primary monitor and the secondary display, for example.
  • Extend: Windows will enlarge and extend your desktop, giving you another screen to work with. This is the option that you will want if you are using an additional monitor for additional personal computer screen space.
  • Second screen only: Windows will turn off your primary display and only use the secondary display.

You may also use the graphics card utility that is installed on your personal computer to configure multiple monitors. Depending on the video or graphics card that is installed in your personal computer, you may have one of the following utilities:

  • Intel Graphics Control Panel or Intel HD Graphics
  • AMD Catalyst Control Center
  • Nvidia Control Panel

Recommended Articles

Here are some recommended articles related to this topic that might be of interest to you.

Affected Products

Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, Alienware and Dell Gaming Monitors, C Series, D Series, E Series, Legacy Monitors, P Series, S Series, SE Series, UltraSharp Premier (UP) Series, UltraSharp (U) Series , G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models, Fixed Workstations, Mobile Workstations ...
Article Properties
Article Number: 000132851
Article Type: Solution
Last Modified: 31 Aug 2024
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.