NetWorkerin passiivisen solmun varmuuskopiointi epäonnistuu DISASTER_RECOVERY: tallenna joukko

Summary: NetWorkerin passiivisen solmun varmuuskopiointi epäonnistuu DISASTER_RECOVERY: save set -toiminnossa.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows-klusteria varmuuskopioidaan NetWorker-asiakasohjelmistolla.
Passiivisen solmun varmuuskopiointi epäonnistuu seuraavien tekijöiden vuoksi:

174424:save: Step (3 of 5) for PID-14480: Creating the snapshot for the selected save sets.
VSS OTHER: ERROR: VSS failed to process snapshot:
176575:save: Unable to save the SYSTEM STATE save sets and create the snapshot.
176571:save: Step (4 of 5) for PID-14480: Unable to complete the backup of the disaster recovery save sets. See the savegrp log to track the closure steps of the backup.
176572:save: Error occurred during the backup of the disaster recovery save sets.


Passiivisen solmun System Event Viewer -lokissa näkyy seuraavat VSS (Volume Shadow Copy Service) -virheet:

Volume Shadow Copy Service error: Unexpected error calling routine GetVolumePathName is fail on the path <>, winerror 0x00000002.. hr = 0x80070002, 
The system cannot find the file specified. 
Operation: PrepareForSnapshot Event Context: Execution Context: Writer Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220} Writer Name: System Writer Writer Instance ID: {df094dcb-34af-4112-a3a1-43febe923b77}

 

Cause

Sovelluspalvelut toimivat jaetussa asemassa, jota ei ole liitetty passiiviseen solmuun paikallisesti vikasietotilan jälkeen.
Järjestelmän kirjoittaja raportoi polun, jossa sovellus on käynnissä.  Volume Shadow Copy Service (VSS) ilmoittaa, että se ei löydä polkua, jossa palvelu on käynnissä.

Resolution

Tarkista "luettelon kirjoittajien yksityiskohtainen" -tulos.
Avaa CMD järjestelmänvalvojana ja suorita seuraava:

diskshadow /l output.txt
DISKSHADOW> list writers detailed
DISKSHADOW> exit
 

1. Avaa NetWorker Management Consolessa (NMC) passiivisen solmun asiakasominaisuudet.
2. Muokkaa Sovellukset ja moduulit -välilehden Tallenna toiminnot - kenttää niin, että se sisältää: 

VSS:NSR_SYS_WRITER_WIN32_SERVCOMP_USER=yes

 

Additional Information

Jos yllä oleva ei auta ratkaisemaan ongelmaa, noudata alla olevia ohjeita ja pyydä tukea avuksi.

Kopioi vsstrace- ja vssagent-binaarit ongelmalliseen asiakasohjelmaan. Ne keräävät paljon Microsoft VSS -virheenkorjaustietoja.

Toimi seuraavasti ja kerää tulokset:

  1. Lisää seuraava syntaksi asiakkaan Varmuuskopiointitoiminnot-kenttään: VSS:NSR_SYS_WRITER_WIN32_SERVCOMP_USER=kyllä
  2. Määritä varmuuskopiointikomento tallentamaan -D9 -vvvv NMC-asiakkaan ominaisuuksiin.
  3. "save -o VSS:LCV=yes" -tulos ongelmallisessa asiakasohjelmassa
  4. savefs -p - lähtö ongelmallisessa asiakkaassa.
  5. Ongelmallisen asiakkaan LCMAP-tuloste.
  6. Ennen kuin aloitat varmuuskopioinnin, aloita ongelmallisen asiakkaan vsstrace- ja vssagent-kokoelma kahdella eri cmd:llä: - vsstrace -l 255 +f 0xffff -o C:\vss.trace.log
  7. Aloita varmuuskopiointi NMC:stä
  8. Odota, että varmuuskopioinnit ovat valmiita.
  9. Kerää tulos komennosta "vssagent -gather C:\VSS.xml"
  10. Kerää NSRGET ja raportit ongelmalliselta asiakkaalta

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000168983
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.