VPLEX. Код признака 0x8a4830dc, мощность нагрузки ИБП ниже ожидаемой
Summary: В этой статье рассказывается о том, какие шаги необходимо предпринять, чтобы подтвердить, является ли зарегистрированный звонок домой реальным событием или ложноположительным событием, и его можно игнорировать. Данная статья относится ко всем платформам VPLEX. ...
Symptoms
Проблема с питанием ниже ожидаемой была зарегистрирована для ИБП, указанных в CDATA сообщения функции «звонок домой», как показано в примере ниже.
Источники бесперебойного питания (ИБП) имеются только в кластерах с двумя или четырьмя узлами.
На VS2 ИБП-А предназначен для резервного питания от аккумулятора коммутатора Fibre-Channel-A и сервера управления, а ИБП-В — для коммутатора Fibre-Channel-B.
В системах VS6 ИБП-А и В предназначены только для коммутаторов Infini-Band (IB).
Пример домашнего вызова, отправленного для этой проблемы:
VS2:
SymptomCode : 0x8a4830dc
Category : Status
Severity : Warning
Status : Warning
Component : DIRECTOR
ComponentID : director-1-2-B << component reporting the issue
SubComponent : ZPEM
CallHome : Yes
FirstTime : 20xx-05-07T01:45:58.048Z
LastTime : 20xx-05-07T01:45:58.048Z
Count : x
CDATA[ups@UPS-B: PartNo 078-000-052/SerialNo QS1303140800 /RevNo 1XE1 :UPS load power is lower than expected [Versions:MS{x.x.x.x}, Director{x.x.x.x.x}]
RCA: The fibre channel switch and/or management server are not plugged in to the UPS.
В этом примере вывода домашнего вызова проблема сообщает, что мощность нагрузки ИБП ниже, чем ожидалось на ИБП-B кластера 1.
Cause
Причина, по которой эти dial-дома сообщают о более низкой, чем ожидалось, мощности нагрузки, может быть следующей:
VS2:
Для ИБП-А
Сервер управления и/или внутренний стоечный коммутатор Fibre-Channel A не видны ИБП.
Для ИБП-В
Для внутреннего монтажа в стойку коммутатор Fibre-Channel B не обнаруживается ИБП.
VS6:
Для ИБП-А
Внутренний стоечный коммутатор Infini-Band (IB) A, одно или оба разъема питания не видны ИБП.
Для ИБП-В
Для внутреннего стоечного коммутатора B с поддержкой Infini-Band (IB) одно или оба разъема питания не видны ИБП.
Resolution
Окончательное решение
В настоящее время инженерный отдел Dell VPLEX изучает эту проблему. Как только исправление станет доступно, эта статья будет обновлена.
Целью данной статьи является проверка состояния любого ИБП, о котором сообщается о «более низких, чем ожидалось, уровнях мощности».
Чтобы понять, как определить, о каком ИБП сообщается об этой проблеме и из какого кластера, посмотрите на ComponentID в сообщении о звонке домой, показанном в разделе «Проблема» выше. В примере сообщения «звонок домой» он показывает, что «director-1-2-B» сообщил о проблеме. Первое отмеченное значение — «1», это идентификатор кластера, поэтому в данном примере это кластер 1. Так как сообщение поступило от директора «B», «director-1-2-B», это означает, что проблема возникла из-за UPS-B. Кроме того, CDATA сообщает вам, для какого UPS был сделан отчет о звонке домой, «ups@UPS-B». ИБП всегда подключены к модулю 2 на любом кластере.
Director-1-2-B
\ \ \ \------------ Это говорит о том, что это ИБП-Б (ИБП-А прикреплены к директорам "А")
\ \-------------- Это говорит о том, что директор находится в движке 2.
\--------------- Это говорит о том, что это кластер 1.
Чтобы проверить, является ли эта проблема реальной или ложной, выполните следующие действия.
VS2:
- Убедитесь, что оба кабеля питания коммутаторов Fibre Channel подключены к соответствующему ИБП и что ИБП подключены к каждому блоку распределения питания (PDU), расположенному на монтажных направляющих стойки.
- Если о событии сообщается для ИБП-А, убедитесь, что кабели питания сервера управления и COM-коммутатора FC A (над сервером управления) подключены к ИБП-А.
- Если о событии сообщается для ИБП-B, убедитесь, что кабель питания коммутатора FC COM B подключен к ИБП-B.
- Проверьте, не ослаблены ли кабели питания от коммутаторов FC COM и сервера управления.
- Убедитесь, что последовательные кабели от каждого ИБП надежно закреплены.
- См. соответствующую схему последовательного подключения кабелей и кабелей питания, прилагаемую к данной статье.
VS6:
- Убедитесь, что оба кабеля питания коммутатора Infini-Band (IB) подключены к соответствующему ИБП и что ИБП подключены к каждому блоку PDS.
- Если о событии сообщается для ИБП-А, убедитесь, что кабели питания коммутатора Infini-Band A подключены к ИБП-А.
- Если о событии сообщается для ИБП В, убедитесь, что кабели питания коммутатора Infini-Band B подключены к ИБП В.
- Проверьте, не ослаблены ли кабели питания от коммутаторов IB.
- Убедитесь, что последовательные кабели от каждого ИБП надежно закреплены.
- См. соответствующую схему последовательного подключения кабелей и кабелей питания, прилагаемую к данной статье.
Чтобы проверить, вернулся ли ИБП в работоспособное состояние, в приведенных ниже примерах будет использоваться кластер 1:
-
Войдите на сервер управления кластером VPLEX, откуда был отправлен отчет о функции «звонок домой»
Пример вывода:
login as: service Using keyboard-interactive authentication. Password: Last login: Day Month Date HH:MM:SS Year from x.x.x.x < IP Address the login is from service@ManagementServer:~>
-
Затем войдите в VPlexcli, используя те же учетные данные, которые использовались для доступа к серверу управления
Пример выходных данных на VPLEX VS2, работающем под управлением версии до 6.x, для версий 6.x второй вход для доступа к VPlexcli не требуется:
service@ ManagementServer:~> vplexcli Trying ::1... Connected to localhost. Escape character is '^]'. Enter User Name: service Password: Creating logfile:/var/log/VPlex/cli/session.log_service_localhost_Logfile_T24531_YYYYMMDDHHMMSS VPlexcli:/>
-
Измените Directory (cd) на контекст UPS и выведите список UPS'
Пример вывода:
VPlexcli:/> cd /clusters/cluster-1/uninterruptible-power-supplies VPlexcli:/clusters/cluster-1/uninterruptible-power-supplies> ll Name ------- ups-2-a ups-2-b
-
Перейдите к уровню контекста UPS, для которого предназначалось оповещение «Звонок домой», и перечислите сведения. Например, если вы вернетесь к образцу сообщения «Звонок домой» в разделе «Проблема» и посмотрите на CDATA. Вы увидите ups@UPS-B, а если вы посмотрите выше на «ComponentID», вы увидите «director-1-2-B». Первая цифра обозначает кластер. В данном случае это «1», указывающая на кластер 1. Перейдите к кластеру 1, перейдите к контексту «uniterruptible-power-supplies», а затем просмотрите ups-2-b, как показано ниже.
Пример вывода:
VPlexcli:/clusters/cluster-1/uninterruptible-power-supplies> cd ups-2-b VPlexcli:/clusters/cluster-1/uninterruptible-power-supplies/ups-2-b> ll
VS2:
Name Value ------------------------ ------------- battery-replacement-date 03/23/10 < date battery was installed in the UPS, if more than 3 years old the UPS must be replaced battery-status fully-charged << check this value battery-time-remaining 5min operational-status online << check this value part-number 078-000-052 << note the part number of the UPS revision-number 1XE1 serial-number <UPS Serial Number>
VS6:
Name Value ------------------------ ------------- battery-replacement-date 09/21/15 battery-status fully-charged << check this value battery-time-remaining 5min operational-status online << check this value part-number 078-000-079 << note the part number of the UPS revision-number FFF serial-number <UPS Serial Number>
Проверка на ложное срабатывание:
-
Если в поле «Состояние аккумулятора» отображается значение « Полностью заряжен», а в «Рабочем состоянии» — « Подключен к сети», проблему можно игнорировать. Скорее всего, оповещение было ложным. Возможно, проблема возникла во время цикла проверки/зарядки аккумулятора, выполняемого ИБП. Это можно подтвердить, сверившись с журналами прошивки с помощью шкафа дат до даты звонка домой, которую можно отметить по образцу сообщения «Звонок домой», приведенному в разделе «Проблема», найдите дату «LastTime», а затем выполните поиск по «серийному номеру» UPS, указанному в CDATA звонка домой в журнале прошивки.
Пример цикла проверки/зарядки аккумулятора ИБП, как указано в журналах микропрограммы:
VS2:
Отчет о мощности нагрузки ниже ожидаемой:128.221.253.38/xmmg/log:5988:W/"154559":109:<4>20xx/11/04 10:36:26.54: ZPEM/220 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : UPS load power is lower than expected.
Отчет о неисправностях ИБП:
128.221.253.38/xmmg/log:5988:W/"154559":110:<3>20xx/11/04 10:36:26.54: ZPEM/471 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : The operational state of the specified fru is Faulted.
Отчет об аккумуляторе ИБП как о зарядке:
128.221.252.38/xmmg/log:5988:W/"154559":111:<4>20xx/11/04 10:36:38.40: ZPEM/211 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : battery-status is Charging <<< this tells us the UPS is in battery test or charging mode
Отчет о том, что ИБП теперь работает, больше не рассматривается как неисправный:
128.221.252.70/xmmg/log:5988:W/"154559":112:<6>20xx/11/04 10:36:38.40: ZPEM/87 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : The operational state of the specified fru has changed to Working. << this says the battery test/charging phase is over and the UPS is back on AC
Проверьте, действительно ли ИБП неисправен:
-
Если в поле «Состояние аккумулятора» отображается «Зарядка », а в разделе «Рабочее состояние» отображается «Онлайн», повторите попытку примерно через 5 минут, так как режим проверки/зарядки аккумулятора все еще может выполняться. Если через пять минут в поле «состояние аккумулятора» отображается состояние зарядки , а в поле «operational-status» — «автономный режим » или «сбой», это может указывать на проблему с ИБП, и неисправный ИБП необходимо заменить.
-
Для замены ИБП необходимо обратиться в службу поддержки VPLEX и сообщить им о своих находках и о необходимости замены ИБП. Упомяните эту статью.
Как связаться со службой поддержки Dell VPLEX с помощью чата:
Чтобы связаться со службой поддержки, для начала перейдите на сайт Dell Support.com. На странице Добро пожаловать в службу поддержки Dell в верхней части страницы, где отображается строка «Поиск Dell или Идентификация продукта», введите «Серия VPLEX», «VPLEX VS2» или «VPLEX VS6», затем прокрутите вниз, найдите справа пункт «Обратиться в службу технической поддержки». Если у вас есть действующий контракт на обслуживание, войдите в систему. Если у вас нет действующего контракта на обслуживание, обратитесь за помощью к местному представителю Dell. При наличии активного контракта на обслуживание после входа в систему должна открыться страница «Технические проблемы», где представлены варианты обращения в службу поддержки VPLEX.
Additional Information
- COM-коммутаторы VS2 FC, сервер управления и распределительные платы
- Коммутаторы VS6 Infini-Band (IB) и блоки распределения питания