Avamar: MCS temizleme, avtar Hatası <16507> hatasıyla başarısız oluyor: Path "var/mc/server_data/prefs/sessionticket.srl
Summary: Avamar: sunucu MCS veritabanı temizleme işlemi avtar hatasıyla başarısız oluyor <16507>: Path "var/mc/server_data/prefs/sessionticket.srl": Toplam işlenen bayt sayısı <#> orijinal veri boyutuyla tutarsız <#> ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
MCS veritabanının yedeği alındığında aşağıdaki hata görülebilir:
avtar Error <16507>: Path "var/mc/server_data/prefs/sessionticket.srl": Toplam işlenen bayt # <> orijinal veri boyutuyla <tutarsız #
>
Sonraki yedeklemeler sorunsuz tamamlanacak.
Cause
Bu hata, yedekleme sırasında sessionticket.srl dosyasına yazılırken ve boyutu değiştiğinde görülür.
Resolution
MCS'yi geri yüklemek için sessionticket.srl gerekli değildir, bu nedenle bu hata güvenle yok sayılabilir.
Geçici çözüm:
Gelecekte bu hatadan kaçınmak isterseniz mcserver.xml dosyasını
değiştirmek için aşağıda sağlanan geçici çözümü izleyin: mcserver.xml herhangi bir değişiklik yapmadan önce dosyanın yedek bir kopyasını oluşturun:
Geçici çözüm:
Gelecekte bu hatadan kaçınmak isterseniz mcserver.xml dosyasını
değiştirmek için aşağıda sağlanan geçici çözümü izleyin: mcserver.xml herhangi bir değişiklik yapmadan önce dosyanın yedek bir kopyasını oluşturun:
cd /usr/local/avamar/var/mc/server_data/prefs/ cp -p mcserver.xml x-mcserver.xml.old.'date -I'
Edit /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml and add the following information to the flush_exclude_subdirs line:
,prefs/sessionticket.srl
So the flush_exclude_subdirs line should appear as follows:
value="mcs_data_dump.sql.restore,postgres/data/base,postgres/data/global,postgres/data/pg_clog,postgres/data/pg_xlog,postgres/data/postmaster.pid,flush,postgres/data/pg_log,postgres/data/pg_tblspc,postgres/data/pg_twophase,postgres/data/pg_multixact,postgres/data/pg_subtrans,postgres/data/pg_stat_tmp,prefs/sessionticket.srl" />
Note that the MCS will need to be restarted for these changes to take affect:
dpnctl stop mcs dpnctl start mcs
Once the next backup of the MCS has been completed you can confirm the sessionticket.srl was not backed up by grepping through the flush.log to confirm;
grep sessionticket.srl /usr/local/avamar/var/mc/server_log/flush.log
2016-10-26 05:50:10 avtar Info <7838>: - "var/mc/server_data/prefs/sessionticket.srl" kullanıcı hariç tutma 2016-10-26 05:52:38 avtar Info <5375>: var/mc/server_data/prefs/sessionticket.srl" hariç tutma deseni için 1 eşleşme. 2016-10-26 06:50:01 avtar Info <5551>: Komut Satırı: /usr/local/avamar/bin/avtar.bin --flagfile=/usr/local/avamar/etc/usersettings.cfg --password=**************** --vardir=/usr/local/avamar/var --server=server-internal --id=root --bindir=/usr/local/avamar/bin --vardir=/usr/local/avamar/var --bindir=/usr/local/avamar/bin --sysdir=/usr/local/avamar/etc -c -v --account=/MC_BACKUPS --nocache --senddata --logfile=var/mc/server_log/flush.log --id=root --password=**************** --retention-type=daily, haftalık,aylık,yıllık var/mc/server_data/ --exclude=var/mc/server_data/mcs_data_dump.sql.restore --exclude=var/mc/server_data/postgres/data/base --exclude=var/mc/server_data/postgres/data/global --exclude=var/mc/server_data/postgres/data/pg_clog --exclude=var/mc/server_data/postgres/data/pg_xlog --exclude=var/mc/server_data/postgres/data/postmaster.pid --exclude=var/mc/server_data/flush --exclude=var/mc/server_data/postgres/data/pg_log --exclude=var/mc/ server_data/postgres/data/pg_tblspc --exclude=var/mc/server_data/postgres/data/pg_twophase --exclude=var/mc/server_data/postgres/data/pg_multixact --exclude=var/mc/server_data/postgres/data/pg_subtrans --exclude=var/mc/server_data/postgres/data/pg_stat_tmp --exclude=var/mc/server_data/prefs/sessionticket.srl --server=server-internal --hfsport=27000 --conntimeout=120 --vardir=/usr/local/avamar/var
Affected Products
AvamarProducts
Avamar, Avamar ServerArticle Properties
Article Number: 000170855
Article Type: Solution
Last Modified: 12 Mar 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.