Avamar: PDM y SnapshotManager no funcionan debido a un problema de memoria de Tomcat
Summary: Avamar: PDM y SnapshotManager no funcionan debido a un problema de memoria de Tomcat.
Symptoms
Avamar 19.7+ implementó una nueva función para comprobar el estado del proxy. Esta función se conecta al servicio CIM en cada proxy (con un ciclo de sondeo predeterminado de 30 minutos) para comprobar el estado de servicios como Jetty, CIM, avagent, FLR y vmtools.
En algunos entornos, este ciclo de sondeo de estado de proxy predeterminado puede provocar agotamiento de la memoria de Tomcat, lo que genera interrupciones en servicios como Snapshot Manager, Deploy Manager (PDM), Client Manager (AAM) y la página principal de Avamar DTLT. Estas interrupciones persistirán hasta que se reinicie el servicio Tomcat.
Impacto en Snapshot Manager:
Cuando se intenta utilizar Snapshot Manager, este informa un error de tiempo de espera agotado (curl 28) después de 60 minutos.
08:49:00 avvcbimage Info : Creating snapshot 'Avamar-1668329340b6216cd5819bac4f61bece141dc1f5035c2c07c6', quiesceFS=1 08:49:00 avvcbimage Info : SnapshotManager: createSnapshot for vmMoref = vm-161785 08:49:00 avvcbimage Info : SnapshotManager: POST to /snapshotmanager/vm/vm-161785/action/createSnapshot 09:49:00 avvcbimage Info : POST: curl_easy_perform failed. Path:/snapshotmanager/vm/vm-161785/action/createSnapshot Curl Error: 28 09:49:00 avvcbimage Info : SnapshotManager: failed to create snapshot 09:49:00 avvcbimage FATAL : [IMG0009] failed to create snapshot, possible timeoutLuego, la anotación de mv de marca tardará otros 60 minutos.
09:49:00 avvcbimage Info : backup Failed, only set annotation to LastBackupStatus 09:49:00 avvcbimage Info : AvSnapMgr::addSetAnnotation, vm-161785 09:49:00 avvcbimage Info : SnapshotManager: POST to /snapshotmanager/vm/vm-161785/action/markAnnotations 09:49:00 avvcbimage Info : Login by loginWS test is OK. 09:49:00 avvcbimage Info : Entering the 'final' phase of termination, timer trigger 10:49:00 avvcbimage Info : POST: curl_easy_perform failed. Path:/snapshotmanager/vm/vm-161785/action/markAnnotations Curl Error: 28
Tomcat:
Cuando se produce el problema, se puede encontrar el siguiente mensaje de error “java.lang.OutOfMemoryError” en los registros de Tomcat ubicados en “/usr/local/avamar/var/dtlt/webapp_log” en el servidor Avamar:root@ave198:/usr/local/avamar/var/log/vcs/#: grep 'java.lang.OutOfMemoryError' /usr/local/avamar-tomcat/logs/* /usr/local/avamar-tomcat/logs/catalina.2022-12-31.log: java.lang.OutOfMemoryError: Java heap space /usr/local/avamar-tomcat/logs/catalina.2022-12-31.log: java.lang.OutOfMemoryError: Java heap space /usr/local/avamar-tomcat/logs/catalina.2022-12-31.log: java.lang.OutOfMemoryError: Java heap spaceProxy Deployment Manager:
Durante este problema, los usuarios no podrán crear recomendaciones de proxy. Es posible que se produzcan errores como HTTP 404 o HTTP 500 cuando se intenta utilizar Proxy Deployment Manager (PDM), o es posible que no reciban errores.
Cause
Error principal de Avamar 337410 en el cual, en algunos entornos, el ciclo de sondeo de estado de proxy predeterminado de 30 minutos puede provocar el agotamiento de la memoria de Tomcat.
Resolution
Avamar 19.7: Este problema se resolvió en la revisión acumulativa 337464
Avamar 19.8: El problema se resolvió en la revisión acumulativa 337920
Instrucción de instalación manual:
Para evitar que este problema de agotamiento de memoria vuelva a ocurrir, puede deshabilitar el sondeo automático de la función de comprobación del estado de proxy.
1. Edite el archivo dm.properties en el servidor Avamar ubicado en /etc/vcs/dm.properties.
2. Busque la opción “enable_status_check_schedule” y cambie su valor a “false”.
Antes
# Is enable status check schedule, default value is true enable_status_check_schedule=trueDespués
# Is enable status check schedule, default value is true enable_status_check_schedule=false
3. Reinicie Tomcat como usuario raíz mediante el siguiente comando: emwebapp.sh --restart
Impacto en la función de estado de administración de proxy: Esta función no tendrá ningún impacto. El estado del proxy se seguirá recuperando cuando el usuario ingrese al menú “Proxy Management > Proxy Status” en la interfaz de usuario web de Avamar (AUI).
Additional Information
Solución alternativa a corto plazo para fallas de respaldo:
Para resolver fallas de respaldo sin reiniciar Tomcat ni realizar cambios en el archivo del servidor dm.properties, puede deshabilitar Snapshot Manager en el proxy de Avamar.
Para mayor orientación, consulte el siguiente artículo de la base de conocimientos: KB 000181611, “Cómo desactivar Snapshot Manager en el proxy de Avamar”.