Avamar - Tomcatのメモリーの問題によりPDMとSnapshotManagerが機能しない

Summary: Avamar - Tomcatのメモリーの問題により、PDMとSnapshotManagerが機能しません。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar 19.7以降では、プロキシ ステータスを確認する新しい機能が実装されています。この機能は、すべてのプロキシのCIMサービスに接続し(デフォルトのポーリング サイクルは30分)、Jetty、CIM、avagent、FLR、vmtoolsなどのサービスのステータスを確認します。

一部の環境では、このデフォルトのプロキシ ステータスのポーリング サイクルによってTomcatのメモリーが不足し、Snapshot Manager、Deploy Manager (PDM)、Client Manager (AAM)、Avamar DTLTホームページなどのサービスが停止する可能性があります。これらのシステム停止は、Tomcatサービスが再起動されるまで続きます。

 

Snapshot Managerへの影響:
Snapshot Managerを使用しようとすると、Snapshot Managerは60分後にタイムアウト エラー(curl 28)を報告します。

08:49:00 avvcbimage Info : Creating snapshot 'Avamar-1668329340b6216cd5819bac4f61bece141dc1f5035c2c07c6', quiesceFS=1
08:49:00 avvcbimage Info : SnapshotManager: createSnapshot for vmMoref = vm-161785
08:49:00 avvcbimage Info : SnapshotManager: POST to /snapshotmanager/vm/vm-161785/action/createSnapshot
09:49:00 avvcbimage Info : POST: curl_easy_perform failed. Path:/snapshotmanager/vm/vm-161785/action/createSnapshot Curl Error: 28
09:49:00 avvcbimage Info : SnapshotManager: failed to create snapshot
09:49:00 avvcbimage FATAL : [IMG0009] failed to create snapshot, possible timeout
次に、「VMアノテーションのマーク」にさらに60分かかります
09:49:00 avvcbimage Info : backup Failed, only set annotation to LastBackupStatus
09:49:00 avvcbimage Info : AvSnapMgr::addSetAnnotation, vm-161785
09:49:00 avvcbimage Info : SnapshotManager: POST to /snapshotmanager/vm/vm-161785/action/markAnnotations
09:49:00 avvcbimage Info : Login by loginWS test is OK.
09:49:00 avvcbimage Info : Entering the 'final' phase of termination, timer trigger
10:49:00 avvcbimage Info : POST: curl_easy_perform failed. Path:/snapshotmanager/vm/vm-161785/action/markAnnotations Curl Error: 28

Tomcat:

この問題が発生すると、Avamar Serverの「/usr/local/avamar/var/dtlt/webapp_log」にあるTomcatログにエラー メッセージ「java.lang.OutOfMemoryError」が表示されます。
root@ave198:/usr/local/avamar/var/log/vcs/#: grep  'java.lang.OutOfMemoryError' /usr/local/avamar-tomcat/logs/*
/usr/local/avamar-tomcat/logs/catalina.2022-12-31.log:  java.lang.OutOfMemoryError: Java heap space
/usr/local/avamar-tomcat/logs/catalina.2022-12-31.log:  java.lang.OutOfMemoryError: Java heap space
/usr/local/avamar-tomcat/logs/catalina.2022-12-31.log:  java.lang.OutOfMemoryError: Java heap space

Proxy Deployment Manager:
この問題が発生している間、ユーザーはプロキシの推奨事項を作成できません。Proxy Deployment Manager (PDM)を使用しようとすると、HTTP 404やHTTP 500などのエラーが発生する場合と発生しない場合があります。

Cause

一部の環境では、Avamarのプライマリー バグ337410により、デフォルトの30分のプロキシ ステータス ポーリング サイクルが原因でTomcatのメモリーが不足する可能性があります。

Resolution

解決策:

Avamar 19.7:この問題は、累積ホットフィックス337464で解決されています。

Avamar 19.8:この問題は、累積ホットフィックス337920で解決されています。


手動インストール手順:

このメモリー不足の問題が再発しないようにするには、プロキシ ステータス チェック機能の自動ポーリングを無効にできます。

1.Avamar Server上の/etc/vcs/dm.propertiesにあるdm.propertiesファイルを編集します。

2.オプション「enable_status_check_schedule」を見つけ、その値を「false」に変更します。

変更前
# Is enable status check schedule, default value is true
enable_status_check_schedule=true
変更後
# Is enable status check schedule, default value is true
enable_status_check_schedule=false

3.emwebapp.sh --restartコマンドを使用して、rootユーザーとしてTomcatを再起動します。

プロキシ管理ステータス機能への影響:この機能には影響しません。ユーザーがAvamar Web UI (AUI)で[Proxy Management]>[Proxy Status]メニューを開くと、プロキシ ステータスは引き続きフェッチされます。

proxy status.png

Additional Information

バックアップの失敗に対する短期的な回避策:

Tomcatを再起動したり、dm.propertiesサーバー ファイルに変更を加えたりせずにバックアップの失敗を解決するには、AvamarプロキシでSnapshot Managerを無効にできます。

詳細については、次のナレッジベース記事を参照してください。KB 000181611 - 「AvamarプロキシでSnapshot Managerを無効化する方法(英語)」

Article Properties
Article Number: 000208326
Article Type: Solution
Last Modified: 26 Jun 2023
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.