PowerProtect : Échec de la restauration SQL DDBMA avec le mode de récupération avec Keep_CDC activé

Summary: La restauration SQL autonome PowerProtect Data Manager et DDBMA avec mode de récupération échoue lorsque keep_CDC est activé.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Même si le mode Restore with Recovery est choisi, l’erreur ci-dessous s’affiche dans le journal :
2024-04-02T05:32:16.909Z 38008  ddbmsqlrc PowerProtect Data Manager critical Option 'norecovery' conflicts with option(s) 'keep_cdc'. Remove the conflicting option and reissue the statement.

Cause

Il s’agit d’un problème connu dans PowerProtect Data Manager (jusqu’à la version 19.16 à partir de maintenant) et DDBMA autonome.

Resolution

Il existe deux solutions de contournement pour le CDC base de données. Choisissez l’une ou l’autre option.

Solution de contournement 1 :
Two restores must be run.

1. Select the second last backup and select norecovery (no keep_cdc option). This can be run from the UI or command line.
2. Select the last backup and select "restore with recovery" and specify keep_cdc option. Generate script and add -z option in the script and run the restore.

The above restores the CDC databases.

This workaround still requires manual process. We request to fix this logic so that the automated process of building recovery chain is without flaws and works for all situations without manual intervention. 

Solution de contournement 2 :
1. Restore the database to a file using DDBEA
2. Restore the database through SSMS with that file
3. Check that the CDC is maintained or not

Restore of database was successful and CDC was maintained too.

Affected Products

PowerProtect Data Manager, PowerProtect App Direct, PowerProtect Software
Article Properties
Article Number: 000224347
Article Type: Solution
Last Modified: 27 Jun 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.