Connectrix NDFC: MDS Alerts are Not Sent to User Email Address, Email Solution Not Working

Summary: Connectrix MDS Series Nexus Dashboard Fabric Controller (NDFC): MDS fabric alert events are not binge sent to the user email address. The traffic between SMTP server and NDFC data vNic is whitelisted. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nexus dashboard

Connectrix NDFC is not forwarding events to the recipient email address. Test email sent to the user's SMTP server, however no email is received. 

Errors noted in the eventmgr.log file from the cisco-ndfc.tgz file embedded in the NDFC techsupport file:

2024-10-25T11-57-50Z-cisco-ndfc-ts-/cisco-ndfc/cisco-ndfc-dcnm-apps-logs/dcnm-eventmgr-data/eventmgr.log

"timestamp": "-",

"level":

"WARN", "thread": "event-forwarder",

"logger": "com.cisco.dcbu.sm.service.server.em.AlertNotifier",

"message": "MessagingException - ERROR forwarding Email to SMTP host w.x.y.z",

"context": "EventManager"

log confirms NDFC could not send the SMTP message successfully to the configured IP [ SMTP host ]

Cause

NDFC could not send the SMTP message successfully to the configured IP [SMTP host].

Resolution

LAN traffic between the SMTP server and NDFC data vNic [Data vNIC maps to bond0] were whitelisted to allow email alerts from NDFC.

Affected Products

Connectrix MDS-Series Nexus Dashboard Fabric Controller
Article Properties
Article Number: 000247579
Article Type: Solution
Last Modified: 13 Nov 2024
Version:  1
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