Backup copies of DDBMA databases are filling up the local C: drive on SQL hosts
Summary: Backup copies of DDBMA databases are filling up the local C: drive on SQL hosts
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Hourly backups are generated in the C:\Program Files\DPSAPPS\AgentService\dbs\v1\backups directory causing the local C drive to be filled up.
Cause
When used in conjunction with PowerProtect Data Manager, the Microsoft application agent takes hourly backups of local sql-lite databases that PowerProtect Data Manager uses for discovery purposes.
By default, these backups are retained for seven days, but this can still cause space constraints.
In situations where PowerProtect Data Manager is not installed in the enterprise, there are 2 possible causes for this behavior
1. When the Microsoft application agent was installed, the option to choose a "PowerProtect Data Manager" was selected when there is, in fact, no PowerProtect Data manager in the customer's network.
2. The appliance hostname or IP address is pointing to something other than a PowerProtect Data Manager (Data Domain, for example).
By default, these backups are retained for seven days, but this can still cause space constraints.
In situations where PowerProtect Data Manager is not installed in the enterprise, there are 2 possible causes for this behavior
1. When the Microsoft application agent was installed, the option to choose a "PowerProtect Data Manager" was selected when there is, in fact, no PowerProtect Data manager in the customer's network.
2. The appliance hostname or IP address is pointing to something other than a PowerProtect Data Manager (Data Domain, for example).
Resolution
Solutions are provided here for installations where PowerProtect is, and is not incorporated in the network.
If you are NOT using PowerProtect Data Manager in your network
On the SQL host where local backups are accumulating:
1. From the Windows Control Panel, click Programs and Features.
2. Select the Microsoft Application Agent, and click "Change".
3. On the "Install Modification" screen, "Change" should be selected.
4. Click Next.
5. Within the Microsoft Application Agent installation window, ensure that the "PowerProtect Data Manager" box is "unchecked".
6. Click Change, to complete the installation changes.
Lastly, All files in the C:\Program Files\DPSAPPS\AgentService\dbs\v1\backups directory can be manually deleted.
Another option for those NOT using PowerProtect Data Manager in their environment (and may not have permissions to install/remove software) is as follows:
1. Click Start, type Services.msc, and press Enter.
2. Locate the PowerProtect Agent Service.
3. Stop the PowerProtect Agent Service.
4. Right-click and select Properties.
5. On the Startup Type: Select "Disabled"
As in the previous option:
All files in the C:\Program Files\DPSAPPS\AgentService\dbs\v1\backups directory can be manually deleted.
If you ARE using PowerProtect Data Manager in your Network
The frequency of the backups, as well as how long they are retained can be changed by modifying the C:\Program Files\DPSAPPS\AgentServiceconfig.yml file.
**Note In the following example, there is a leading space before the number 72. it is important when modifying yml files that there is no extra spaces.
backup_retention:
# agent service backup retention time in hours, default is 3days = 72
72
STEPS:
1. Make a copy of the C:\Program Files\DPSAPPS\AgentService\config.yml file
2. Open the current C:\Program Files\DPSAPPS\AgentService\config.yml file in a text editor such as Notepad.
3. Look for the following options /values:
backup_retention:
# agent service backup retention time in hours, default is 7days = 168h.
168
/internal/agent/datastore-backup:
recurringInterval: 60
4. Modify these values as follows:
backup_retention:
# agent service backup retention time in hours, default is 3days = 72
72
/internal/agent/datastore-backup:
recurringInterval: 720
5. Exit your text editor and save the changes to the config.yml.
6. The last step is to click on Start, type Services.msc and press Enter to launch the Windows Services app.
7. Find the PowerProtect Agent Service.
8. Stop and Start this service and the new retention and backup interval settings will be in effect.
If you are NOT using PowerProtect Data Manager in your network
On the SQL host where local backups are accumulating:
1. From the Windows Control Panel, click Programs and Features.
2. Select the Microsoft Application Agent, and click "Change".
3. On the "Install Modification" screen, "Change" should be selected.
4. Click Next.
5. Within the Microsoft Application Agent installation window, ensure that the "PowerProtect Data Manager" box is "unchecked".
6. Click Change, to complete the installation changes.
Lastly, All files in the C:\Program Files\DPSAPPS\AgentService\dbs\v1\backups directory can be manually deleted.
Another option for those NOT using PowerProtect Data Manager in their environment (and may not have permissions to install/remove software) is as follows:
1. Click Start, type Services.msc, and press Enter.
2. Locate the PowerProtect Agent Service.
3. Stop the PowerProtect Agent Service.
4. Right-click and select Properties.
5. On the Startup Type: Select "Disabled"
As in the previous option:
All files in the C:\Program Files\DPSAPPS\AgentService\dbs\v1\backups directory can be manually deleted.
If you ARE using PowerProtect Data Manager in your Network
The frequency of the backups, as well as how long they are retained can be changed by modifying the C:\Program Files\DPSAPPS\AgentServiceconfig.yml file.
**Note In the following example, there is a leading space before the number 72. it is important when modifying yml files that there is no extra spaces.
backup_retention:
# agent service backup retention time in hours, default is 3days = 72
72
STEPS:
1. Make a copy of the C:\Program Files\DPSAPPS\AgentService\config.yml file
2. Open the current C:\Program Files\DPSAPPS\AgentService\config.yml file in a text editor such as Notepad.
3. Look for the following options /values:
backup_retention:
# agent service backup retention time in hours, default is 7days = 168h.
168
/internal/agent/datastore-backup:
recurringInterval: 60
4. Modify these values as follows:
backup_retention:
# agent service backup retention time in hours, default is 3days = 72
72
/internal/agent/datastore-backup:
recurringInterval: 720
5. Exit your text editor and save the changes to the config.yml.
6. The last step is to click on Start, type Services.msc and press Enter to launch the Windows Services app.
7. Find the PowerProtect Agent Service.
8. Stop and Start this service and the new retention and backup interval settings will be in effect.
Affected Products
Data Backup & Protection SoftwareArticle Properties
Article Number: 000192680
Article Type: Solution
Last Modified: 21 Oct 2021
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.