RecoverPoint: CG er ved en fejl og RPA er nede i RecoverPoint-systemer, der bruger samme Unity-system

Summary: Replikering af fejlende konsistensgrupper og RecoverPoint-enheder (RPA er), der går ind i genstartsregulering på flere RecoverPoint-systemer ved hjælp af det samme Unity-system.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Replikeringsproblemer starter på flere RecoverPoint-systemer, der bruger det samme Unity-system efter oprettelse af en ny konsistensgruppe (CG) eller tilføjelse af journaldiskenheder på eksisterende CG'er.

Fra systemhændelser (CLI):
  Topic:                GROUP
  Scope:                DETAILED
  Level:                ERROR
  Event ID:             4040
  Summary:              Journal error
  More information:     Full sweep to be performed.

  Topic:                GROUP
  Scope:                ADVANCED
  Level:                INFO
  Event ID:             4075
  Summary:              Journal available

  Topic:                GROUP
  Scope:                NORMAL
  Level:                WARNING
  Event ID:             4082
  Summary:              The dirtying action took place either due to a user action (e.g. group was enabled or journal volumes changed) or due to a system fatal error.
  There will be only one full sweep on this link in the next synchronization, regardless of the number of times the link's copies are marked as dirty until the synchronization starts.
  More information:     The copy marked all of its replication volumes as dirty.



Fra replikeringslogfiler:
2022/09/07 23:27:48.185 - #0 - 16558/16380 - Stream: errno=0 Assertion failed: false Line 2142 File /home/builderv/ReleaseBuilds/rel-hydra_patch1/src/kashya_infra/stream/Stream.inl PID: 16380 Info: Trying to get head from a stream without open it first
END OF LOGGER

2022/09/07 20:40:31.781 - #0 - 7714/7467 - Stream: errno=0 Assertion failed: false Line 2149 File /home/builderv/ReleaseBuilds/rel-hydra_patch1/src/kashya_infra/stream/Stream.inl PID: 7467 Info: Stream must be recovered or init before get head
END OF LOGGER

2022/09/07 21:39:29.335 - #0 - 13316/12743 - NO TOPIC: errno=0 Assertion failed: 0 Line 89 File SerializableQueueElement.cc PID: 12743 Info: NO INFO
END OF LOGGER

Cause

Dette problem opstår, når flere RPA er fra forskellige RecoverPoint-systemer skriver til de samme kladdediskenheder.  Når dette sker, bliver journalhistorikken for begge CG'er beskadiget og starter en fuld oprydning for at sikre datakonsistens. Dette udløser også genstart af replikeringsprocessen, hvilket fører til genstartsregulering på RPA erne.

Resolution

Opløsning:
Kontrollér, at hver konsistensgruppe indeholder unikke journalbind i alle RecoverPoint-systemer. (Admin CLI-kommandoen "get_group_volumes" kan være nyttig til at identificere de journaldiskenheder, der bruges på tværs af hvert system.)

  1. På påvirkede CG'er skal du navigere til fanen Kladde.
  2. Klik på knappen "Rediger tidsskrifter", vælg ny journalvolumen, der skal føjes til CG, og ryd problemet Journal Volume.

Additional Information

Dokumenteret i "Dell EMC RecoverPoint Deploying with Midrange Storage Technical Notes", side 7 under Begrænsninger:
I modsætning til VNX har Unity ikke storagegrupper. Derfor er alle diskenheder synlige for alle RPA-klynger, herunder diskenheder, der allerede er beskyttet af andre RPA-klynger. Sørg for, at du kun beskytter ubeskyttede diskenheder. Hvis du beskytter en enhed, der allerede er beskyttet:
  • Replikering starter ikke
  • Linktilstanden angiver, at systemet har sat på pause
  • En fejl angiver, at diskenhederne allerede er beskyttet
  • Databeskadigelse kan forekomme, hvis den valgte diskenhed er en journaldiskenhed i en anden RPA-klynge

Affected Products

RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint SE
Article Properties
Article Number: 000203635
Article Type: Solution
Last Modified: 22 Sept 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.