RecoverPoint. Группы консистентности по ошибке и RPA в системах RecoverPoint, использующих один и тот же массив Unity

Summary: Сбой репликации групп консистентности и включение устройств RecoverPoint (RPA) в режим перезагрузки в нескольких системах RecoverPoint, использующих один и тот же дисковый массив Unity. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Проблемы с репликацией начинаются в нескольких системах RecoverPoint, использующих один и тот же массив Unity, после создания новой группы консистентности или добавления томов журнала в существующие группы консистентности.

Из системных событий (интерфейс командной строки):
  Topic:                GROUP
  Scope:                DETAILED
  Level:                ERROR
  Event ID:             4040
  Summary:              Journal error
  More information:     Full sweep to be performed.

  Topic:                GROUP
  Scope:                ADVANCED
  Level:                INFO
  Event ID:             4075
  Summary:              Journal available

  Topic:                GROUP
  Scope:                NORMAL
  Level:                WARNING
  Event ID:             4082
  Summary:              The dirtying action took place either due to a user action (e.g. group was enabled or journal volumes changed) or due to a system fatal error.
  There will be only one full sweep on this link in the next synchronization, regardless of the number of times the link's copies are marked as dirty until the synchronization starts.
  More information:     The copy marked all of its replication volumes as dirty.



Из журналов репликации:
2022/09/07 23:27:48.185 - #0 - 16558/16380 - Stream: errno=0 Assertion failed: false Line 2142 File /home/builderv/ReleaseBuilds/rel-hydra_patch1/src/kashya_infra/stream/Stream.inl PID: 16380 Info: Trying to get head from a stream without open it first
END OF LOGGER

2022/09/07 20:40:31.781 - #0 - 7714/7467 - Stream: errno=0 Assertion failed: false Line 2149 File /home/builderv/ReleaseBuilds/rel-hydra_patch1/src/kashya_infra/stream/Stream.inl PID: 7467 Info: Stream must be recovered or init before get head
END OF LOGGER

2022/09/07 21:39:29.335 - #0 - 13316/12743 - NO TOPIC: errno=0 Assertion failed: 0 Line 89 File SerializableQueueElement.cc PID: 12743 Info: NO INFO
END OF LOGGER

Cause

Эта проблема возникает, когда несколько устройств RPA из разных систем RecoverPoint записывают данные в одни и те же тома журнала.  В этом случае журнал для обеих групп консистентности повреждается и инициирует полную очистку для обеспечения согласованности данных. Это также инициирует перезапуск процесса репликации, что приводит к регулированию перезагрузки RPA.

Resolution

Резолюция:
Убедитесь, что каждая группа консистентности содержит уникальные тома журнала во всех системах RecoverPoint. (Команда интерфейса командной строки администратора «get_group_volumes» может быть полезна для определения томов журнала, используемых в каждой системе.)

  1. В затронутых группах консистентности перейдите на вкладку «Журнал» целевой копии.
  2. Нажмите кнопку "Редактировать журналы", выберите новый том журнала для добавления в группу консистентности и снимите проблему с томом журнала.

Additional Information

Документировано в документе «Технические примечания к развертыванию Dell EMC RecoverPoint с хранилищем среднего уровня», стр. 7, в разделе Ограничения:
В отличие от VNX, в Unity нет групп хранения. Таким образом, все тома видны всем кластерам RPA, включая тома, которые уже защищены другими кластерами RPA. Обеспечьте защиту только незащищенных томов. Если вы защищаете уже защищенный том:
  • Репликация не начинается
  • Состояние канала указывает: Приостановлено системой
  • Ошибка указывает на то, что тома уже защищены
  • Повреждение данных может произойти, если выбранный том является томом журнала в другом кластере RPA

Affected Products

RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint SE
Article Properties
Article Number: 000203635
Article Type: Solution
Last Modified: 22 Sept 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.