Точка відновлення: CG у помилках та RPAs у системах RecoverPoint, які використовують той самий масив Unity
Summary: Помилка реплікації груп узгодженості та входження RecoverPoint Appliances (RPAs) у Reboot Regulation на кількох системах RecoverPoint з використанням одного масиву Unity.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Проблеми з реплікацією починаються на кількох системах RecoverPoint, які використовують один і той самий масив Unity, після створення нової групи узгодженості (CG) або додавання томів журналів на існуючих CG.
Із подій системи (CLI):
З журналів реплікацій:
Із подій системи (CLI):
Topic: GROUP Scope: DETAILED Level: ERROR Event ID: 4040 Summary: Journal error More information: Full sweep to be performed. Topic: GROUP Scope: ADVANCED Level: INFO Event ID: 4075 Summary: Journal available Topic: GROUP Scope: NORMAL Level: WARNING Event ID: 4082 Summary: The dirtying action took place either due to a user action (e.g. group was enabled or journal volumes changed) or due to a system fatal error. There will be only one full sweep on this link in the next synchronization, regardless of the number of times the link's copies are marked as dirty until the synchronization starts. More information: The copy marked all of its replication volumes as dirty.
З журналів реплікацій:
2022/09/07 23:27:48.185 - #0 - 16558/16380 - Stream: errno=0 Assertion failed: false Line 2142 File /home/builderv/ReleaseBuilds/rel-hydra_patch1/src/kashya_infra/stream/Stream.inl PID: 16380 Info: Trying to get head from a stream without open it first END OF LOGGER 2022/09/07 20:40:31.781 - #0 - 7714/7467 - Stream: errno=0 Assertion failed: false Line 2149 File /home/builderv/ReleaseBuilds/rel-hydra_patch1/src/kashya_infra/stream/Stream.inl PID: 7467 Info: Stream must be recovered or init before get head END OF LOGGER 2022/09/07 21:39:29.335 - #0 - 13316/12743 - NO TOPIC: errno=0 Assertion failed: 0 Line 89 File SerializableQueueElement.cc PID: 12743 Info: NO INFO END OF LOGGER
Cause
Ця проблема виникає, коли кілька RPA з різних систем RecoverPoint записуються в одні й ті ж томи журналу. Коли це відбувається, історія журналу для обох CG пошкоджується та ініціює повну зачистку для забезпечення стабільності даних. Це також запускає перезапуск процесу реплікації, що призводить до регулювання перезавантаження RPA.
Resolution
Резолюція:
Переконайтеся, що кожна група узгодженості містить унікальні томи журналів у всіх системах RecoverPoint. (Команда командного рядка адміністратора "get_group_volumes" може бути корисною для визначення томів журналу, що використовуються в кожній системі.)
- Щодо порушених CG перейдіть на вкладку «Журнал» цільової копії.
- Натисніть кнопку "Редагувати журнали", виберіть новий Journal Volume для додавання в CG і зніміть проблему з Journal Volume.
Additional Information
Задокументовано в "Dell EMC RecoverPoint Deploying with Midrange Storage Technical Notes" на сторінці 7 у розділі "Обмеження:
На відміну від VNX, Unity не має груп зберігання". Таким чином, усі томи видно для всіх кластерів RPA, включно з тими, які вже були захищені іншими кластерами RPA. Переконайтеся, що ви захищаєте лише незахищені томи. Якщо ви захищаєте вже захищений том:
На відміну від VNX, Unity не має груп зберігання". Таким чином, усі томи видно для всіх кластерів RPA, включно з тими, які вже були захищені іншими кластерами RPA. Переконайтеся, що ви захищаєте лише незахищені томи. Якщо ви захищаєте вже захищений том:
- Реплікація не починається
- Стан з'єднання вказує на призупинення системою
- Помилка вказує на те, що томи вже захищені
- Пошкодження даних може відбутися, якщо вибраний том є журнальним томом в іншому кластері RPA
Affected Products
RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint SEArticle Properties
Article Number: 000203635
Article Type: Solution
Last Modified: 22 Sept 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.