PowerEdge: Dispositivo di avvio inaccessibile di Windows
Summary: Il server genera il codice di arresto 0x7B: Dispositivo di avvio inaccessibile.
Symptoms
Il software antivirus o di backup potrebbe essere stato installato, aggiornato o rimosso di recente.
Cause
La causa più probabile dell'errore "Dispositivo di avvio inaccessibile", oltre a un guasto hardware o ad altri problemi che impediscono l'accesso all'installazione di Windows, è un driver di filtro danneggiato o mancante.
Webroot, Acronis ArcServee i prodotti StorageCraft sono i trasgressori più comuni.
Resolution
1. Eseguire l'avvio dal supporto di installazione di Windows appropriato per accedere a WinRE.
2. Da "Installa Windows", selezionare "Avanti", quindi cliccare su "Ripristina il computer".
3. Da "System Recovery Options", selezionare "Next", quindi cliccare su "Command Prompt".
4. Eseguire "DiskPart", quindi "List Vol" e prendere nota della lettera dell'unità del volume del sistema operativo.
5. Eseguire "Exit" per uscire da DiskPart.
Avvertimento: Se non viene visualizzato il volume del sistema operativo, eseguire "List Disk": se lo storage non è presente, si è verificato un problema hardware o è necessario caricare il driver del controller (uscire da DiskPart eseguendo "Exit", copiare il driver del controller sull'unità USB, collegarlo al server, eseguire "drvload PATH_TO_CONTROLLER_INF_FILE").
6. Passare al volume del sistema operativo eseguendo "cd /d Z:\" oppure "Z:."
Nota: Sostituire "Z:\" OS volume's actual drive letter which was obtained by running "List Vol" from DiskPart.
7. Passare alla directory di configurazione eseguendo "cd Z:\Windows\System32\config."
8. Esegui "mkdir Backup" poi "copy SYSTEM Backup\SYSTEM" per eseguire un backup del file hive del registro di sistema.
9. Esegui "reg load HKLM\Temp SYSTEM" per caricare il file hive del registro di sistema.
10 Eseguire "regedit" quindi passare a "HKLM\Temp\ControlSet001\Control\Class."
11 Fare clic su "Modifica", quindi su "Trova" o premere "CTRL+F", quindi cercare "upperfilters."
12 Si stanno cercando driver di filtro di terze parti che sono stati inseriti nel "UpperFilters" chiave del Registro di sistema delle classi correlate allo storage. Documentare i nomi di eventuali driver di filtro estranei o imprevisti, quindi rimuoverli modificando la finestra di dialogo UpperFilters chiave del Registro di sistema. Cliccare su "Find Next" o premere "F3" per procedere.
Impostazione predefinita per DiskDrive Classe:
Impostazione predefinita per SmartCardReader Classe:
Impostazione predefinita per SmrDisk Classe:
Impostazione predefinita per ScmDisk Classe:
Impostazione predefinita per Volume Class:
13 Se nel passaggio precedente sono stati trovati e rimossi driver di filtro di terze parti, passare a "HKLM\Temp\ControlSet001\Services", quindi cercare il nome del driver di filtro. Documentare il nome del servizio corrispondente, quindi impostarne "Start" chiave del Registro di sistema su "0" per disabilitarla. Cliccare su "Find Next" o premere "F3" per verificare che non siano stati trovati riferimenti.
Quattordici Chiudi regedit quindi esegui "reg unload HKLM\Temp" per scaricare l'hive del Registro di sistema.
15 Riavviare il server.
Ulteriori considerazioni:
se l'errore è causato da driver di filtro di terze parti, consigliare al cliente di disinstallare/reinstallare il software problematico.
Se i driver di filtro di terze parti non sono il tuo colpevole e l'hardware è stato escluso, allora si torna alle basi.
16 Esegui "bcdedit", verificare che siano presenti voci per il boot manager e il loader di Windows.
Output di esempio:
Avvertenza: Se non viene restituito nulla da BCDEDIT in caso di problemi con i dati della configurazione di avvio (BCD), risolverli di conseguenza. Una possibile soluzione potrebbe essere quella di ricreare il BCD eseguendo "bootrec /rebuildbcd."
17 Eseguire "Dism /Image:Z:\ /Get-Packages", verificare che non vi siano aggiornamenti in sospeso. Se sono presenti aggiornamenti in sospeso, è possibile ripristinarli eseguendo "Dism /Image:Z:\ /Cleanup-Image /RevertPendingActions", quindi riavviare.
18 Eseguire "Chkdsk Z:" per eseguire una scansione read-only. Se viene rilevato un danneggiamento di NTFS, è possibile eseguire "Chkdsk /f /r Z:" per eseguire una riparazione. Chkdsk è potenzialmente distruttivo, cioè può causare la perdita di dati.
19 Corri "sfc /scannow /offbootdir=Z:\ /offwindir=Z:\Windows" per analizzare/tentare di riparare i file di sistema.
Venti Sostituire i file hive del registro di sistema con i backup da RegBack directory:
Esegui "cd Z:\Windows\System32\config."
Esegui "ren DEFAULT DEFAULT.old."
Esegui "ren SAM SAM.old."
Esegui "ren SECURITY SECURITY.old."
" Eseguireren SOFTWARE SOFTWARE.old.
Esegui "ren SYSTEM SYSTEM.oldFunzionamento del "
"copy RegBack\DEFAULT DEFAULT."
Esegui "copy RegBack\SAM SAM."
Esegui "copy RegBack\SECURITY SECURITY."
Esegui "copy RegBack\SOFTWARE SOFTWARE."
Esegui "copy RegBack\SYSTEM SYSTEM."
21 Riavviare il server.