PowerEdge. Недоступное загрузочное устройство Windows

Summary: Сервер генерирует код остановки 0x7B: Недоступное загрузочное устройство.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

После перезагрузки или отключения питания сервер генерирует код остановки 0x7B: Недоступное загрузочное устройство. 

Возможно, антивирусное ПО или ПО для резервного копирования было недавно установлено, обновлено или удалено.

Cause

Наиболее вероятной причиной ошибки «Недоступное загрузочное устройство», помимо аппаратного сбоя или другой проблемы, препятствующей доступу к установке Windows, является поврежденный или отсутствующий драйвер фильтра.

Веб-корень, Acronis ArcServe, а продукты StorageCraft являются наиболее распространенными нарушителями.

Resolution

1. Загрузите систему с соответствующего установочного носителя Windows, чтобы войти в среду WinRE.
2. В меню «Установка Windows» выберите «Далее», затем нажмите «Восстановить компьютер».
3. В меню «Параметры восстановления системы» выберите «Далее», затем нажмите «Командная строка».
4. Запустите «DiskPart», затем «List Vol» — запишите букву диска тома ОС.
5. Выполните команду «Exit», чтобы выйти из DiskPart.

Предупреждение: Если том ОС не отображается, выполните команду «Список дисков». - Если хранилище отсутствует, либо у вас проблема с оборудованием, либо необходимо загрузить драйвер контроллера (Покиньте DiskPart, выполнив команду «Exit», скопируйте драйвер контроллера на USB-накопитель, подключите его к серверу, выполните команду «drvload PATH_TO_CONTROLLER_INF_FILE").

6. Перейдите к тому ОС, выполнив команду «cd /d Z:\" или "Z:
Заметка: Заменять "Z:\" OS volume's actual drive letter which was obtained by running "List Vol" from DiskPart.
7. Перейдите в каталог конфигурации, выполнив команду «cd Z:\Windows\System32\config
8. Выполните команду "mkdir Backup" затем "copy SYSTEM Backup\SYSTEM» для создания резервной копии файла куста системного реестра.
9. Выполните команду "reg load HKLM\Temp SYSTEM» для загрузки файла куста системного реестра.
10 Запустите "regedit», затем перейдите в раздел «HKLM\Temp\ControlSet001\Control\Class
11 Нажмите «Изменить», затем «Найти» или нажмите «CTRL+F», затем выполните поиск «upperfilters

12 Вы ищете драйверы фильтров сторонних производителей, которые были интегрированы в "UpperFilters" раздела реестра классов, связанных с хранилищем. Запишите имена всех внешних или неожиданных драйверов фильтров, а затем удалите их, отредактировав файл UpperFilters Раздел реестра. Нажмите «Find Next» или «F3», чтобы продолжить.

По умолчанию для DiskDrive Класс:
Редактор реестра 
По умолчанию для SmartCardReader Класс:

Редактор реестра 

По умолчанию для SmrDisk Класс:
Редактор реестра 

По умолчанию для ScmDisk Класс:
Редактор реестра 

По умолчанию для класса тома:
Редактор реестра 

13 Если вы нашли и удалили драйверы сторонних фильтров на предыдущем шаге, перейдите в раздел "HKLM\Temp\ControlSet001\Services», а затем найдите имя драйвера фильтра. Запишите имя соответствующей службы, затем задайте для нее значение "Start" в значение "0", чтобы отключить его. Нажмите «Find Next» или «F3», чтобы убедиться, что ссылки не найдены.

Четырнадцать Закройте regedit, затем выполните "reg unload HKLM\Temp», чтобы выгрузить куст системного реестра.
15 Перезагрузите сервер.

Дополнительные замечания.Если

сбой был вызван драйверами фильтра сторонних производителей, посоветуйте заказчику удалить/переустановить проблемное программное обеспечение.

Если драйверы фильтра сторонних производителей не являются виновниками, а оборудование было исключено, вернемся к истокам.

16 Запустите "bcdedit», убедитесь в наличии записей для диспетчера загрузки и загрузчика Windows.
Пример выходных данных:
выходные данные команды 

Предупреждение! Если ничего не возвращено функцией BCDEDIT проблема с данными конфигурации загрузки (BCD), устраните проблему соответствующим образом. Потенциальным решением может быть повторное создание BCD с помощью команды "bootrec /rebuildbcd

17 Выполните "Dism /Image:Z:\ /Get-Packages», убедитесь в отсутствии ожидающих обновлений. При наличии ожидающих обновлений их можно отменить, выполнив команду «Dism /Image:Z:\ /Cleanup-Image /RevertPendingActions», а затем перезагрузите компьютер.

18 Запустите "Chkdsk Z:» для выполнения сканирования только для чтения. При обнаружении повреждения NTFS можно выполнить команду «Chkdsk /f /r Z:» для выполнения ремонта. Chkdsk потенциально деструктивна, то есть может привести к потере данных. 

19 Запустите "sfc /scannow /offbootdir=Z:\ /offwindir=Z:\Windows» для сканирования/попытки восстановления системных файлов.

Двадцать Замените файлы куста реестра резервными копиями из RegBack directory:
Выполните команду "cd Z:\Windows\System32\config
Выполните команду "ren DEFAULT DEFAULT.old
Выполните команду "ren SAM SAM.old
Выполните команду "ren SECURITY SECURITY.old."
" Выполнитеren SOFTWARE SOFTWARE.old.
Выполните команду "ren SYSTEM SYSTEM.old«
Выполнить»copy RegBack\DEFAULT DEFAULT
Выполните команду "copy RegBack\SAM SAM
Выполните команду "copy RegBack\SECURITY SECURITY
Выполните команду "copy RegBack\SOFTWARE SOFTWARE
Выполните команду "copy RegBack\SYSTEM SYSTEM
21 Перезагрузите сервер.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350 , PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000221200
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.