Connectrix Cisco MDS: Řetězce hesel MDS by měly umožňovat otazník (?) při zadávání prostého textu.
Summary: Heslo NX-OS se znaménkem "?" Na všech platformách MDS nelze znaky zadávat v rozhraní příkazového řádku nebo pomocí skriptu, jako je například NX-OS CLI.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Heslo NX-OS s "?"" Znak nelze zadat v rozhraní příkazového řádku nebo pomocí skriptu, protože analyzátor NX-OS CLI jej interpretuje jako vložený příkaz nápovědy.
Příklad:
switch(config)# username san-admin password 123?
WORD Password for the user (clear text) (Max Size 127)
WORD Password for the user (clear text) (Max Size 64)
switch(config)# tacacs-server host x.x.x.x key 7 LP,K?
WORD TACACS+ shared secret(encrypted) (Max Size 63)
Cause
K problému dochází při konfiguraci normálního hesla i hesla uživatele AAA na přepínačích MDS.
Resolution
Zástupné řešení:
- Před každou kombinaci kláves "ctrl-v" přidejte před každé "?" Znak.
Další popis problému:
- Tento problém může zabránit použití stejného hesla v produktech od více dodavatelů jako "?" Znak je akceptován v heslech jinými dodavateli.
Známé postižení softwaru Cisco MDS 9000 NX-OS a SAN-OS – 8.3(1)
Opravit: Známé opravené verze: 8.4(2) a novější
Poznámka:
- Doporučuje se nepoužívat otazník (?) v heslech normálního uživatele nebo AAA.
Additional Information
Osvědčené postupy naleznete v "Příručce konfigurace zabezpečení Cisco Nexus řady 9000 NX-OS".
Pro uživatelské jméno:
- Uživatelská jména musí začínat alfanumerickým znakem a mohou obsahovat pouze tyto speciální znaky: ( + = . _ \ -).
- Modely # a ! Symboly nejsou podporovány. Pokud uživatelské jméno obsahuje znaky, které nejsou povoleny, zadaný uživatel se nemůže přihlásit.
Pro heslo:
- V heslech zařízení Cisco Nexus lze použít speciální znaky, jako je znak dolaru ($) nebo znak procenta (%).
Affected Products
Connectrix MDS-SeriesArticle Properties
Article Number: 000212190
Article Type: Solution
Last Modified: 14 Apr 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.