Connectrix Cisco MDS: MDS-passordstrenger bør tillate spørsmålstegn (?) i klar tekst.

Summary: Et NX-OS-passord med "?" Tegn kan ikke skrives inn på CLI eller ved hjelp av et skript som NX-OS CLI på alle MDS-plattformer.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Et NX-OS passord med en "?"" Tegn kan ikke skrives inn på CLI eller bruke et skript, da NX-OS CLI-parseren tolker det som den innebygde hjelpekommandoen.
 

Eksempel:
switch(config)# username san-admin password 123?
  WORD Password for the user (clear text) (Max Size 127)
  WORD Password for the user (clear text) (Max Size 64)


switch(config)# tacacs-server host x.x.x.x key 7 LP,K?
  WORD  TACACS+ shared secret(encrypted) (Max Size 63)

Cause


Problemet oppstår når du konfigurerer både normale passord og AAA-brukerpassord på MDS-svitsjer.

Resolution


Omgåelse av problemet:
  • Lag en 'ctrl-v' tastekombinasjon før hver "?" Tegn.

Ytterligere problembeskrivelse:
  • Dette problemet kan forhindre at du bruker samme passord på produkter fra flere leverandører som "?" Tegn godtas i passord av andre leverandører.  

Cisco MDS 9000 NX-OS og SAN-OS Kjent berørt programvare – 8.3(1)

Fiksere: Kjente faste versjoner: 8.4 (2) og nyere

Merk:
– Foreslo å ikke bruke spørsmålstegn (?) i vanlige bruker- eller AAA-brukerpassord.

Additional Information


Anbefalte fremgangsmåter se "Veiledning for sikkerhetskonfigurasjon for Cisco Nexus 9000-serien NX-OS"

For brukernavn:
  • Brukernavn må begynne med et alfanumerisk tegn og kan bare inneholde disse spesialtegnene: ( + = . _ \ -). 
  • Den # og! Symboler støttes ikke. Hvis brukernavnet inneholder tegn som ikke er tillatt, kan ikke den angitte brukeren logge på.

For Password:
  • Spesialtegn, for eksempel dollartegnet ($) eller prosenttegnet (%), kan brukes i Cisco Nexus-enhetspassord.

Affected Products

Connectrix MDS-Series
Article Properties
Article Number: 000212190
Article Type: Solution
Last Modified: 14 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.