Connectrix Cisco MDS: MDS-lösenordssträngar bör tillåta frågetecken (?) i klartextinmatning.
Summary: Ett NX-OS-lösenord med ett "?" Det går inte att ange tecknet i CLI eller med ett skript som NX-OS CLI på alla MDS-plattformar.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Ett NX-OS-lösenord med ett "?"" Det går inte att ange tecknet i CLI eller med ett skript eftersom NX-OS CLI-parsern tolkar det som det infogade hjälpkommandot.
Exempel:
switch(config)# username san-admin password 123?
WORD Password for the user (clear text) (Max Size 127)
WORD Password for the user (clear text) (Max Size 64)
switch(config)# tacacs-server host x.x.x.x key 7 LP,K?
WORD TACACS+ shared secret(encrypted) (Max Size 63)
Cause
Problemet uppstår när du konfigurerar både normala lösenord och AAA-användarlösenord på MDS-switchar.
Resolution
Alternativ lösning:
- Lägg till en "ctrl-v"-tangentkombination före varje "?" Karaktär.
Ytterligare problembeskrivning:
- Det här problemet kan förhindra att samma lösenord används på produkter från flera leverantörer som "?" Tecknet accepteras i lösenord av andra leverantörer.
Cisco MDS 9000 NX-OS- och SAN-OS-programvara som är känd påverkad – 8.3(1)
Reparera: Kända åtgärdade versioner: 8.4(2) och senare
Anmärkning:
- Rekommenderas att inte använda frågetecken (?) i de vanliga användar- eller AAA-användarlösenorden.
Additional Information
Bästa praxis, se "Manual för NX-OS-säkerhetskonfiguration för Cisco Nexus 9000-serien"
För användarnamn:
- Användarnamn måste börja med ett alfanumeriskt tecken och får endast innehålla dessa specialtecken: ( + = . _ \ -).
- Operatorerna # och ! Symboler stöds inte. Om användarnamnet innehåller tecken som inte är tillåtna kan den angivna användaren inte logga in.
För lösenord:
- Specialtecken, t.ex. dollartecknet ($) eller procenttecknet (%), kan användas i lösenord för Cisco Nexus-enheter.
Affected Products
Connectrix MDS-SeriesArticle Properties
Article Number: 000212190
Article Type: Solution
Last Modified: 14 Apr 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.