Plataforma de administración de PowerFlex: El usuario de LDAP no puede realizar llamadas a la API
Summary: Un usuario habilitado para LDAP recibe un error "no hay ninguna función asignada al usuario" cuando realiza llamadas a la API.
Symptoms
Situación
Un usuario de LDAP puede iniciar sesión a través de la interfaz de usuario, pero no puede realizar llamadas a la API. Mensaje de error como se ve en la captura de pantalla a continuación: "No se asignó ninguna función al usuario":
Impacto
No se puede usar la API con el usuario de LDAP.
Cause
Una falla de diseño de software no permite reconocer la función de usuario de LDAP si el usuario solo forma parte de una función de grupo.
Cuando se utiliza SSO, se asigna un usuario de LDAP a un grupo de LDAP y el grupo de LDAP está configurado con una función de usuario, el comando de inicio de sesión de REST falla debido a que "no se asignó ninguna función al usuario".
Resolution
La solución alternativa es agregar el usuario a la sección Usuarios o grupos remotos en la IU. Incluso si el usuario ya está en uno de los grupos enumerados. El error se produce cuando no se encuentra el tipo de usuario para una llamada de API.
En la siguiente imagen, a pesar de que el usuario "xxxxx" es miembro del grupo sio_admin , el usuario no puede realizar llamadas a la API hasta que agreguemos el usuario aquí como Tipo = Usuario.
Si el usuario "xxxx" se elimina de esta sección, no se permitirán llamadas a la API. El usuario debe existir con un tipo = usuario.
Additional Information
Versión afectada
PFMP 4.x