Piattaforma di gestione PowerFlex: Utente LDAP impossibilità di effettuare chiamate API
Summary: Un utente abilitato per LDAP riceve un errore "no role assigned to user" quando effettua chiamate API.
Symptoms
Scenario
Un utente LDAP può accedere tramite l'interfaccia utente, ma non può effettuare chiamate API. Messaggio di errore visualizzato nella schermata seguente: "Nessun ruolo assegnato all'utente":
Impatto
Impossibile utilizzare l'API con l'utente LDAP.
Cause
Un difetto di progettazione del software non consente di riconoscere il ruolo utente LDAP se l'utente fa solo parte di un ruolo del gruppo.
Quando si utilizza SSO, un utente LDAP viene assegnato a un gruppo LDAP e il gruppo LDAP è configurato con un ruolo utente, il comando di accesso REST ha esito negativo per "no role assigned to user".
Resolution
La soluzione alternativa consiste nell'aggiungere l'utente alla sezione Remote Users/Groups nell'interfaccia utente di Anche se l'utente fa già parte di uno dei gruppi elencati. Il bug si verifica quando il tipo User non viene trovato per una chiamata API.
Nell'immagine riportata di seguito, anche se l'utente "xxxxx" è membro del gruppo sio_admin , non può effettuare chiamate API finché non aggiungiamo l'utente come Type = User.
Se l'utente "xxxx" viene rimosso da questa sezione, non saranno consentite le chiamate API. L'utente deve esistere con un tipo = User.
Additional Information
Versione interessata
PFMP 4.x